change usbtunerhelper src_uri.
[vuplus_openembedded] / recipes / xserver-common / xserver-common_1.32.bb
1 DESCRIPTION = "Common X11 scripts and support files"
2 LICENSE = "GPL"
3 SECTION = "x11"
4 RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo"
5 PR = "r1"
6
7 PACKAGE_ARCH = "all"
8 DEFAULT_PREFERENCE = "-1"
9
10 # we are using a gpe-style Makefile
11 inherit gpe
12
13 SRC_URI_append = " file://setDPI.sh \
14                    file://89xdgautostart.sh"
15
16 SRC_URI_append_angstrom = " file://xtscal-fix.patch;patch=1 "
17 RDEPENDS_${PN}_append_angstrom = " tslib-calibrate "
18
19 do_install_append() {
20         install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
21         install -m 0755 "${WORKDIR}/89xdgautostart.sh" "${D}/etc/X11/Xsession.d/89xdgautostart"
22         sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/Xserver
23 }