Merge remote-tracking branch 'dm/opendreambox-1.6' into test_0701
[vuplus_openembedded] / recipes / xserver-common / xserver-common_1.22.bb
1 DESCRIPTION = "Common X11 scripts and support files"
2 LICENSE = "GPL"
3 SECTION = "x11"
4 RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo"
5 PR = "r11"
6
7 PACKAGE_ARCH = "all"
8
9 # we are using a gpe-style Makefile
10 inherit gpe
11
12 SRC_URI_append = " file://setDPI.sh "
13 SRC_URI_append_angstrom = " file://kdrive-1.4-fixes.patch;patch=1 \
14                             file://xorg-fixes.patch;patch=1 \
15                             file://gta-xorg-fixes.patch;patch=1 \
16                             file://default.xmodmap \
17                             file://98keymap-fixup "
18
19 do_install_append() {
20         install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
21 }
22
23 do_install_append_angstrom() {
24         install -m 0644 ${WORKDIR}/default.xmodmap ${D}/etc/X11/
25         install -m 0755 ${WORKDIR}/98keymap-fixup  ${D}/etc/X11/Xinit.d/
26 }