increase dvbapp PR.
[vuplus_openembedded] / recipes / xorg-xserver / xserver-kdrive_git.bb
1 DEFAULT_PREFERENCE = "-2"
2
3 require xserver-kdrive-common.inc
4 PV = "1.4+git${SRCDATE}"
5
6 DEPENDS += "libxkbfile libxcalibrate pixman"
7
8 PE = "1"
9 PR = "${INC_PR}.0"
10
11 FILESPATH = "${FILE_DIRNAME}/xserver-kdrive-git:${FILE_DIRNAME}/xserver-kdrive"
12 SRC_URI = "git://anongit.freedesktop.org/xorg/xserver;protocol=git \
13         ${KDRIVE_COMMON_PATCHES} \
14         file://enable-epson.patch;patch=1 \
15         file://fix_default_mode.patch;patch=1 \
16         file://enable-xcalibrate.patch;patch=1 \
17         file://hide-cursor-and-ppm-root.patch;patch=1 \
18         file://xcalibrate_coords.patch;patch=1 \
19         file://w100.patch;patch=1 \
20         file://w100-autofoo.patch;patch=1 \
21         file://w100-fix-offscreen-bmp.patch;patch=1 \
22         file://w100-new-input-world-order.patch;patch=1 \
23         file://w100-post-1.4-buildfix.patch;patch=1 \
24         file://xcalibrate-new-input-world-order.patch;patch=1 \
25         file://tslib-default-device.patch;patch=1 \
26         file://fbdev-evdev.patch;patch=1 \
27         file://xephyr-post-1.4-buildfix.patch;patch=1 \
28         "
29
30 S = "${WORKDIR}/git"
31
32 W100_OECONF = "--disable-w100"
33 W100_OECONF_arm = "--enable-w100"
34
35 EXTRA_OECONF += "--enable-builtin-fonts"