increase dvbapp PR.
[vuplus_openembedded] / recipes / xorg-xserver / xserver-kdrive-xomap_1.1.99.3.bb
1 LICENSE = "MIT"
2 DEPENDS = "tslib xproto libxdmcp xextproto xtrans libxau virtual/libx11 libxext libxrandr fixesproto damageproto libxfont resourceproto compositeproto calibrateproto recordproto videoproto scrnsaverproto xpext xsp libxkbfile dbus"
3
4 PROVIDES = "virtual/xserver"
5 PACKAGES =+ "xserver-kdrive-xomap"
6 SECTION = "x11/base"
7 DESCRIPTION = "X server from freedesktop.org"
8 DESCRIPTION_xserver-kdrive-xomap = "X server for the OMAP in the Nokia 800"
9
10 PR = "r3"
11 PE = "1"
12
13 COMPATIBLE_MACHINE = "nokia(800|770)"
14
15 FILES_${PN} = "${libdir}/xserver /etc/dbus-1/* ${bindir}/Xomap"
16
17 SRC_URI = "http://repository.maemo.org/pool/maemo3.1/free/source/xorg-server_1.1.99.3-0osso31.tar.gz \
18         file://kmode.patch;patch=1 \
19         file://disable-apm.patch;patch=1 \
20         file://no-serial-probing.patch;patch=1 \
21         file://fbdev-not-fix.patch;patch=1  \
22         file://enable-builtin-fonts.patch;patch=1 \
23         file://xcalibrate.patch;patch=1 \
24         file://fixups.patch;patch=1 \
25         file://button_only.patch;patch=1 \
26         file://calibrateext.patch;patch=1 \
27         file://fix-picturestr-include-order.patch;patch=1 \
28         file://xcalibrate_coords.patch;patch=1 \
29         file://report-correct-randr10.patch;patch=1"
30 #       file://kdrive-evdev.patch;patch=1  \
31 #       file://kdrive-use-evdev.patch;patch=1  \
32 #       file://optional-xkb.patch;patch=1 \
33 #       file://disable-xf86-dga-xorgcfg.patch;patch=1 \
34 #       file://enable-tslib.patch;patch=1 \
35 #       file://xfbdev-fb-opt.patch;patch=1"
36
37 S = "${WORKDIR}/xorg-server-1.1.99.3"
38
39 inherit autotools pkgconfig 
40
41 EXTRA_OECONF = "--enable-composite --enable-kdrive --enable-builtin-fonts \
42                 --disable-dga --disable-dri --disable-xinerama \
43                 --disable-xf86misc --disable-xf86vidmode \
44                 --disable-xorg --disable-xorgcfg \
45                 --disable-dmx --enable-xcalibrate \ 
46                 --disable-xkb --disable-xnest --disable-xvfb \
47                 --disable-xevie --disable-xprint --disable-xtrap \
48                 --with-default-font-path=built-ins \
49                 ac_cv_file__usr_share_sgml_X11_defs_ent=no \
50                 --enable-xomap"
51
52 do_configure_prepend() {
53     sed -i -e 's/tslib-0.0/tslib-1.0/' ${S}/configure.ac
54 }