Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / xorg-font / xfonts-xorg_6.8.bb
1 SECTION = "x11/base"
2 PR = "r1"
3 # XXX Is this true?  These fonts are from X.org.
4 LICENSE = "XFree86"
5
6 PACKAGE_ARCH = "${BASE_PACKAGE_ARCH}"
7
8 SRC_URI = "${FREEDESKTOP_CVS}/xorg;module=xc;tag=XORG-6_8_0;method=pserver \
9         file://lexer.patch;patch=1"
10
11
12 PACKAGES = "${PN}-dbg ${PN}-75dpi ${PN}-100dpi ${PN}-type1 ${PN}-cyrillic ${PN}-ttf ${PN}"
13 FILES_${PN}-75dpi = "${libdir}/X11/fonts/75dpi"
14 FILES_${PN}-100dpi = "${libdir}/X11/fonts/100dpi"
15 FILES_${PN}-type1 = "${libdir}/X11/fonts/Type1"
16 FILES_${PN}-ttf = "${libdir}/X11/fonts/TTF"
17 FILES_${PN}-cyrillic = "${libdir}/X11/fonts/cyrillic"
18 FILES_${PN} = "${libdir}/X11/fonts"
19
20 PACKAGE_ARCH = "all"
21
22 S = "${WORKDIR}/xc"
23
24 do_configure() {
25         echo "#define ProjectRoot /usr" >> config/cf/host.def
26         echo "#define XnestServer NO"  >> config/cf/host.def
27         echo "#define XdmxServer NO"  >> config/cf/host.def
28         echo "#define CcCmd ${BUILD_CC}" >> config/cf/host.def
29         echo "#define LdCmd ${BUILD_LD}" >> config/cf/host.def
30         echo "#define BuildFreetype2Library YES" >> config/cf/host.def
31         echo "#define HasFreetype2 NO" >> config/cf/host.def
32         echo "" > config/cf/date.def
33         make -C config/imake -f Makefile.ini CC="${BUILD_CC}" BOOTSTRAPCFLAGS="${BUILD_CFLAGS}" clean imake
34         make CC="${BUILD_CC}" xmakefile
35         make Makefiles
36         make clean
37 }
38
39 do_compile() {
40         #make depend
41         make includes
42         make -C config/util
43         make -C lib/freetype2
44         make -C lib/font
45         make -C lib/fontenc
46         make -C lib/fontconfig
47         make -C programs/mkfontscale
48         make -C programs/bdftopcf
49         make -C programs/fc-cache
50         make -C fonts
51 }
52
53 do_install() {
54         make -C fonts DESTDIR="${D}" install
55 }
56
57 do_stage() {
58         :
59 }