increase dvbapp PR
[vuplus_openembedded] / recipes / xmms / xmms_1.2.10.bb
1 DESCRIPTION = "The X MultiMedia System"
2 HOMEPAGE = "http://www.xmms.org/"
3 LICENSE = "GPL"
4 SECTION = "x11/multimedia"
5 # TODO add esd
6 DEPENDS = "gtk+-1.2 libvorbis mikmod alsa-lib libsm esound"
7
8 SRC_URI = "http://www.xmms.org/files/1.2.x/xmms-${PV}.tar.bz2 \
9            file://gcc4.patch;patch=1 \
10            file://xmms-config-dequote.patch;patch=1 \
11            file://acinclude.m4 \
12            file://xmms.sh"
13 PR = "r5"
14
15 RRECOMMENDS_${PN} = "xmms-plugin-output-oss xmms-plugin-output-alsa \
16                     xmms-mad xmms-tremor"
17
18 inherit autotools binconfig
19
20 # TODO enable esd
21 EXTRA_OECONF = "--disable-opengl --disable-esd \
22                 --with-vorbis-includes=${STAGING_INCDIR} \
23                 --with-ogg-includes=${STAGING_INCDIR} \
24                 --with-vorbis-libraries=${STAGING_LIBDIR} \
25                 --with-ogg-libraries=${STAGING_LIBDIR}"
26
27 do_configure_prepend() {
28         cp ${WORKDIR}/acinclude.m4 ${S}
29         rm ${S}/libxmms/acinclude.m4 || true
30         for i in $(find . -name "Makefile*") ; do
31                 sed -i -e 's:MKINSTALLDIRS = @MKINSTALLDIRS@:MKINSTALLDIRS = @mkdir_p@:g' \ 
32                    -e 's:$(SHELL) $(MKINSTALLDIRS):$(MKINSTALLDIRS):g' $i
33         done
34 }
35
36 do_install_append() {
37         install -m 0755 ${WORKDIR}/xmms.sh ${D}${bindir}
38         install -d ${D}${datadir}/applications
39
40         install xmms/xmms.desktop                             ${D}${datadir}/applications
41         sed -i "s/Exec=xmms/Exec=xmms.sh/"                    ${D}${datadir}/applications/xmms.desktop
42         sed -i "s/comment/Comment/"                           ${D}${datadir}/applications/xmms.desktop
43         sed -i "s/Encoding=Legacy-Mixed/StartupNotify=true/"  ${D}${datadir}/applications/xmms.desktop
44         sed -i "s/Terminal=0/Terminal=false/"                 ${D}${datadir}/applications/xmms.desktop
45         sed -i "s/Type=Application/Type=Application\nCategories=AudioVideo;/" ${D}${datadir}/applications/xmms.desktop
46
47         install -d ${D}${datadir}/pixmaps
48         install xmms/xmms_mini.xpm ${D}${datadir}/pixmaps
49 }
50
51 PACKAGES_DYNAMIC = "xmms-plugin-effect-* xmms-plugin-general-* \
52                     xmms-plugin-input-* xmms-plugin-output-* \
53                     xmms-plugin-visualisation-*"
54
55 python populate_packages_prepend () {
56         import os.path
57
58         xmms_libdir = bb.data.expand('${libdir}/xmms', d)
59         effects_root = os.path.join(xmms_libdir, 'Effect')
60         general_root = os.path.join(xmms_libdir, 'General')
61         input_root = os.path.join(xmms_libdir, 'Input')
62         output_root = os.path.join(xmms_libdir, 'Output')
63         visualisation_root = os.path.join(xmms_libdir, 'Visualization')
64
65         do_split_packages(d, effects_root, '^lib(.*)\.so$', 'xmms-plugin-effect-%s', 'XMMS Effect plugin for %s')
66         do_split_packages(d, general_root, '^lib(.*)\.so$', 'xmms-plugin-general-%s', 'XMMS General plugin for %s')
67         do_split_packages(d, input_root, '^lib(.*)\.so$', 'xmms-plugin-input-%s', 'XMMS Input plugin for %s')
68         do_split_packages(d, output_root, '^lib(.*)\.so$', 'xmms-plugin-output-%s', 'XMMS Output plugin for %s')
69         do_split_packages(d, visualisation_root, '^lib(.*)\.so$', 'xmms-plugin-visualization-%s', 'XMMS Visualization plugin for %s')
70 }
71
72 do_stage() {
73         autotools_stage_all
74 }
75
76 FILES_${PN} = "${bindir}/xmms ${bindir}/xmms.sh ${libdir}/libxmms*.so.* \
77                ${datadir}/applications/xmms.desktop \
78                ${datadir}/pixmaps/xmms_mini.xpm"