increase dvbapp PR.
[vuplus_openembedded] / recipes / xmltv / xmltv_0.5.56.bb
1 DESCRIPTION="xmltv; epg grabbers for e.g. mythtv"
2
3 PARALLEL_MAKE = ""
4 SRC_URI="http://downloads.sourceforge.net/xmltv/xmltv-${PV}.tar.bz2 \
5          file://Makefile.PL.patch;patch=1"
6
7 RDEPENDS = "perl \
8             libarchive-zip-perl \
9             libdate-manip-perl \
10             libdatetime-format-strptime-perl \
11             libfile-slurp-perl \
12             libhtml-parser-perl \
13             libhtml-treebuilder-perl \
14             libhttp-cache-transparent-perl \
15             libio-stringy-perl libxml-dom-perl \
16             libio-zlib-perl \
17             liblingua-en-numbers-ordinate \
18             liblinux-dvb-perl \
19             libsoap-lite-perl \
20             libterm-progressbar-perl \
21             libtermreadkey-perl \
22             libtimedate-perl \
23             libunicode-string-perl \
24             libunicode-utf8simple-perl \
25             libwww-mechanize-perl \
26             libwww-perl \
27             libxml-parser-perl \
28             libxml-twig-perl \
29             libxml-writer-perl \
30             perl-module-exporter-heavy \
31             perl-module-file-glob \
32             perl-module-getopt-long \
33             "
34
35 DEPENDS = "perl \
36            libarchive-zip-perl-native \
37            libdate-manip-perl-native \
38            libdatetime-format-strptime-perl-native \
39            libfile-slurp-perl-native \
40            libhtml-parser-perl-native \
41            libhtml-treebuilder-perl-native \
42            libhttp-cache-transparent-perl-native \
43            libio-stringy-perl-native \
44            libio-zlib-perl-native \
45            liblingua-en-numbers-ordinate-native \
46            liblinux-dvb-perl-native \
47            libsoap-lite-perl-native \
48            libterm-progressbar-perl-native \
49            libtermreadkey-perl-native \
50            libtimedate-perl-native \
51            libunicode-string-perl-native \
52            libunicode-utf8simple-perl-native \
53            libwww-mechanize-perl-native \
54            libwww-perl-native \
55            libxml-dom-perl-native \
56            libxml-parser-perl-native \
57            libxml-twig-perl-native \
58            libxml-writer-perl-native \
59            "
60
61 PR = "r4"
62
63 # cpan does not work, it installs things in the perl work dir iso the xmltv work dir
64 # root cause are bad definitions in perl/config.sh, but I don't know what they should be
65 # so for now commented out the cpan stuff and do the work myself.
66 #EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
67
68 #inherit cpan
69
70 FILES_${PN} += "${libdir}"
71
72 do_configure() {
73         perl Makefile.PL PREFIX=/usr
74         sed -i -e 's,$(FIXIN),echo,g' \
75                -e 's,^FIXIN.*,,g' Makefile
76 }
77
78
79 do_install() {
80         oe_runmake install DESTDIR=${D}
81 }