increase dvbapp PR.
[vuplus_openembedded] / recipes / xml-commons / xpp2_2.1.10.bb
1 DESCRIPTION = "Streaming pull XML parser for java"
2 LICENSE = "BSD-like"
3
4 HOMEPAGE = "http://www.extreme.indiana.edu/xgws/xsoap/xpp/"
5
6 SRC_URI = "http://www.extreme.indiana.edu/xgws/xsoap/xpp/download/PullParser2/PullParser2.1.10.tgz"
7
8 S = "${WORKDIR}/PullParser${PV}"
9
10 inherit java-library
11
12 DEPENDS = "fastjar-native virtual/javac-native"
13
14 do_compile() {
15         if [ -d build-oe ]; then
16                 rm -rf build-oe
17         fi
18   mkdir -p build-oe
19
20         sourcepath="src/java/drivers/jaxp11:src/java/drivers/sax2:src/java/impl/factory:src/java/impl/format:src/java/impl/node:src/java/impl/pullparser:src/java/impl/tag:src/java/intf"
21
22         findpath="${sourcepath//:/ }"
23
24   javac -sourcepath $sourcepath -d build-oe `find $findpath -name "*.java"`
25
26         mkdir -p build-oe/META-INF/services
27         cp src/java/drivers/jaxp11/META-INF/services/javax.xml.parsers.SAXParserFactory build-oe/META-INF/services
28         cp src/java/impl/factory/META-INF/services/org.gjt.xpp.XmlPullParserFactory build-oe/META-INF/services
29
30   fastjar -C build-oe -c -f ${JARFILENAME} .
31 }