increase dvbapp PR.
[vuplus_openembedded] / recipes / xinetd / xinetd_2.3.13.bb
1 DEPENDS = ""
2 DESCRIPTION = "Highly configurable, modular and secure inetd"
3 PR ="r4"
4
5 SRC_URI = "http://www.xinetd.org/xinetd-${PV}.tar.gz \
6           file://xinetd.init \
7           file://xinetd.conf \
8           file://service.c.patch;patch=1 \
9           "
10
11 EXTRA_OECONF="--disable-nls"
12
13 inherit autotools update-rc.d
14
15 INITSCRIPT_NAME = "xinetd"
16 INITSCRIPT_PARAMS = "defaults"
17
18 do_configure() {
19         # Looks like configure.in is broken, so we are skipping
20         # rebuilding configure and are just using the shipped one
21         oe_runconf
22 }
23
24 INHIBIT_AUTO_STAGE = "1"
25
26 do_install() {
27         # Same here, the Makefile does some really stupid things,
28         # but since we only want two files why not override
29         # do_install from autotools and doing it ourselfs?
30         install -d "${D}/usr/sbin"
31         install -d "${D}/etc/init.d"
32         install -d "${D}/etc/xinetd.d"
33         install -m 644 "${WORKDIR}/xinetd.conf" "${D}/etc"
34         install -m 755 "${WORKDIR}/xinetd.init" "${D}/etc/init.d/xinetd"
35         install -m 755 "${S}/xinetd/xinetd" "${D}/usr/sbin"
36         install -m 755 "${S}/xinetd/itox" "${D}/usr/sbin"
37
38 }
39
40 CONFFILES_${PN} = "${sysconfdir}/xinetd.conf"