increase dvbapp PR.
[vuplus_openembedded] / recipes / xfce-base / xfce4-panel_4.6.2.bb
1 # xfce4-panel OE build file
2
3 DESCRIPTION = "Xfce4 Panel"
4 DEPENDS = "virtual/libx11 startup-notification libxfcegui4 libxml2 exo libwnck"
5 SECTION = "x11"
6 PR = "r1"
7
8 inherit xfce46
9
10 EXTRA_OECONF += " --enable-startup-notification"
11
12 do_stage() {
13     autotools_stage_all
14 }
15
16 do_install() {
17     oe_runmake DESTDIR=${D} install
18 }
19
20 python populate_packages_prepend() {
21         plugin_dir = bb.data.expand('${libdir}/xfce4/panel-plugins/', d)
22         plugin_name = bb.data.expand('${PN}-plugin-%s', d)
23         do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
24                           '${PN} plugin for %s', extra_depends='', prepend=True,
25                           aux_files_pattern=['${datadir}/xfce4/panel-plugins/%s.desktop',
26                                              '${sysconfdir}/xdg/xfce/panel/%s-*',
27                                              '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
28                                              '${bindir}/*%s*'])
29 }
30
31 PACKAGES_DYNAMIC = "${PN}-plugin-*"