change usbtunerhelper src_uri.
[vuplus_openembedded] / recipes / xerces-j / xerces-j_2.9.1.bb
1 DESCRIPTION = "Reference implementation of XNI, the Xerces Native Interface, and also a fully conforming XML Schema processor."
2 LICENSES = "AL2.0"
3 AUTHOR = "Apache Software Foundation"
4
5 SRC_URI = "http://www.apache.org/dist/xerces/j/Xerces-J-src.${PV}.tar.gz"
6
7 S = "${WORKDIR}/xerces-2_9_1"
8
9 inherit java-library
10
11 JPN = "libxerces2-java"
12
13 DEPENDS = "fastjar-native jaxp1.3 xml-commons-resolver1.1"
14 RDEPENDS = "libjaxp1.3-java libxml-commons-resolver1.1-java"
15
16 do_unpackpost() {
17   find src -exec \
18     sed -i -e "s|@impl.name@|Xerces-J ${PV}|" \
19            -e "s|@impl.version@|${PV}|" {} \;
20 }
21
22 addtask unpackpost after do_unpack before do_patch
23
24 JARFILENAME = "xercesImpl.jar"
25 ALTJARFILENAMES = ""
26
27 do_compile() {
28   mkdir -p build
29
30   # Prepend the bootclasspath with the earlier XML API to make
31   # compilation succeed.
32   oe_makeclasspath bcp -s jaxp-1.3 resolver
33         bcp=$bcp:${STAGING_DATADIR_NATIVE}/classpath/glibj.zip
34
35   javac -sourcepath src -d build -bootclasspath $bcp `find src -name "*.java"`
36
37   (cd src && find org ! -name "*.java" -exec cp {} ../build/{} \;)
38
39   fastjar -C build -c -m src/manifest.xerces -f ${JARFILENAME} .
40
41   # Like Debian we provide a symlink called xmlParserAPIs.jar pointing to the JAXP
42   # classes.
43   ln -sf ${D}${datadir_java}/xmlParserAPIs.jar jaxp-1.3.jar
44
45 }