increase dvbapp PR.
[vuplus_openembedded] / recipes / xdiskusage / xdiskusage_1.48.bb
1 DESCRIPTION = "Xdiskusage shows graphically what is using up your disk space"
2 AUTHOR = "Bill Spitzak"
3 HOMEPAGE = "http://xdiskusage.sourceforge.net/"
4 SECTION = "x11/applications"
5 PRIORITY = "optional"
6 LICENSE = "GPL"
7 DEPENDS = "fltk"
8
9 SRC_URI = "http://xdiskusage.sourceforge.net/xdiskusage-${PV}.tgz \
10            file://running_from_menu.patch;patch=1 \
11            file://xdiskusage.desktop \
12            file://xdiskusage.png"
13
14 EXTRA_OEMAKE = "CXXFLAGS="${CXXFLAGS} `fltk-config --cxxflags`" \
15                 LDLIBS="`fltk-config --ldflags`""
16
17 do_install() {
18     install -d ${D}/${bindir}
19     install -d ${D}/${mandir}/man1
20     install -d ${D}/${datadir}/applications
21     install -d ${D}/${datadir}/pixmaps
22     install -m 0755 ${S}/xdiskusage ${D}/${bindir}/
23     install -m 0644 ${S}/xdiskusage.1 ${D}/${mandir}/man1/
24     install -m 0644 ${WORKDIR}/xdiskusage.desktop ${D}/${datadir}/applications/
25     install -m 0644 ${WORKDIR}/xdiskusage.png ${D}/${datadir}/pixmaps/
26 }