Merge branch 'opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / xchat / xchat_2.8.6.bb
1 DESCRIPTION = "Full-featured IRC chat client with scripting support"
2 LICENSE = "GPL"
3 HOMEPAGE = "http://www.xchat.org"
4 SECTION = "x11/network"
5 DEPENDS = "libgcrypt zlib gtk+"
6 DEPENDS += "gdk-pixbuf-csource-native"
7 PR = "r1"
8
9 SRC_URI = "http://www.xchat.org/files/source/2.8/xchat-${PV}.tar.bz2"
10
11 inherit autotools
12
13 EXTRA_OECONF = "\
14   --disable-perl \
15   --disable-python \
16   --disable-tcl \
17 "
18
19 #Fix little bug that slipped into the 2.8.6 release, already fixed upstream.
20 do_compile_prepend() {
21         sed -i 's/GtkType/GType/' ${s}src/fe-gtk/xtext.{c,h}
22 }
23
24 FILES_${PN} += "${datadir}/dbus-1"
25                 
26 FILES_${PN}-dbg += "${libdir}/xchat/plugins/.debug"