enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / xapian / xapian-bindings-python_1.0.14.bb
1 DESCRIPTION = "Open Source Search Engine Library python bindings"
2 HOMEPAGE = "http://xapian.org"
3 SECTION = "devel/libs"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "xapian-core xapian-core-native"
7 PR = "r0"
8
9 SRC_URI = "http://www.oligarchy.co.uk/xapian/${PV}/xapian-bindings-${PV}.tar.gz"
10
11 S = "${WORKDIR}/xapian-bindings-${PV}"
12
13 inherit autotools pkgconfig distutils-base
14
15 export XAPIAN_CONFIG = "${STAGING_BINDIR_NATIVE}/xapian-config"
16
17 EXTRA_OECONF = "--with-python --without-php --without-ruby --without-tcl \
18                 --without-csharp --without-java"
19
20 do_configure () {
21         BUILD_SYS=${BUILD_SYS} HOST_SYS=${MULTIMACH_HOST_SYS} \
22         autotools_do_configure
23 }
24
25 # we don't want make to generate pyc and pyo files, but make install
26 # expects them later
27 do_compile() {
28         oe_runmake PYTHON=true
29         touch ${S}/python/xapian.pyc
30         touch ${S}/python/xapian.pyo
31 }
32
33 # workaround for bad installation destination and removal of fake .py? files
34 do_install_append() {
35         mv ${D}/${STAGING_DIR_HOST}/usr/* ${D}/usr/
36         rm ${D}/usr/lib/python2.6/site-packages/xapian.py?
37 }
38
39 do_stage () {
40      autotools_stage_all
41 }
42