Merge remote-tracking branch 'dm/opendreambox-1.6' into test_0701
[vuplus_openembedded] / recipes / wpa-supplicant / wpa-gui_0.6.9.bb
1 DESCRIPTION = "Qt interface for choosing which configured network to connect \
2 to. It also provides a method for browsing 802.11 SSID scan results, an event \
3 history log of messages generated by wpa_supplicant, and a method to add or \
4 edit wpa_supplicant networks."
5 SECTION = "network"
6 LICENSE = "GPL BSD"
7 HOMEPAGE = "http://hostap.epitest.fi/wpa_supplicant/"
8 DEPENDS = "librsvg-native imagemagick-native"
9 RDEPENDS = "wpa-supplicant"
10 RRECOMMENDS = "${LIBC}-gconv-utf-16"
11 PR = "r1"
12
13 SRC_URI = "http://hostap.epitest.fi/releases/wpa_supplicant-${PV}.tar.gz\
14          file://icons.patch;patch=1 \
15          file://session_manager.patch;patch=1 "
16
17 SRC_URI_append_shr = "file://desktop.patch;patch=1 \
18                       file://style"
19
20 S = "${WORKDIR}/wpa_supplicant-${PV}/wpa_supplicant/wpa_gui-qt4"
21
22 inherit qt4x11
23 ARM_INSTRUCTION_SET = "arm"
24
25 do_compile_append() {
26        oe_runmake -C ${S}/icons
27 }
28
29 do_install () {
30        install -d ${D}${bindir}
31        install -d ${D}${datadir}/wpa_gui
32        install -d ${D}${datadir}/applications
33        install -d ${D}${datadir}/pixmaps
34        install -m 644 icons/hicolor/128x128/apps/wpa_gui.png ${D}${datadir}/pixmaps
35        install -m 755 wpa_gui ${D}/${bindir}
36        install -m 644 wpa_gui.desktop ${D}/${datadir}/applications
37 }
38
39 do_install_append_shr() {
40        install -m 644 ${WORKDIR}/style ${D}/${datadir}/wpa_gui
41 }
42
43 FILES_${PN} = "/usr/share/pixmaps/wpa_gui.png \
44                /usr/share/wpa_gui/style \
45                /usr/bin/wpa_gui \
46                /usr/share/applications/wpa_gui.desktop"
47
48 FILES_${PN}_append_shr = " /usr/share/wpa_gui/style"