Merge remote-tracking branch 'dm/opendreambox-1.6' into test_0701
[vuplus_openembedded] / recipes / wifi-radar / wifi-radar_1.9.6.bb
1 SECTION = "x11/network"
2 DESCRIPTION="WiFi Radar is a Python/PyGTK2  utility for managing WiFi profiles."
3 HOMEPAGE="http://www.bitbuilder.com/wifi_radar/"
4 LICENSE = "GPL"
5
6 PR = "r2"
7
8 PACKAGE_ARCH = "all"
9
10 RDEPENDS = "python-core python-pygtk python-re python-io python-pygobject python-pycairo"
11
12 SRC_URI="http://wifi-radar.systemimager.org/pub/${PN}-${PV}.tar.bz2 \
13         file://wifi-radar.patch;patch=1 \
14         file://wifi-radar_destktop.patch;patch=1 "
15
16
17 S = "${WORKDIR}/${PN}-${PV}"
18
19 do_install() {
20     oe_runmake sbindir=${D}${sbindir} initdir=${D}${sysconfdir}/init.d sysconfdir=${D}${sysconfdir} mandir=${D}${mandir} pixmapsdir=${D}${datadir}/pixmaps appsdir=${D}${datadir}/applications install
21
22     #sbindir    = /usr/sbin
23     #initdir    = /etc/init.d
24     #sysconfdir         = /etc/wifi-radar
25     #mandir             = /usr/share/man
26     #pixmapsdir         = /usr/share/pixmaps
27     #appsdir    = /usr/share/applications
28 }
29
30 pkg_postinst() {
31 #!/bin/sh
32 # post installation script
33 echo "*******************************************"
34 echo "Please edit /etc/wifi-radar.conf"
35 echo "to match your wifi card name (wlan0, eth0, ...)"
36 echo "*******************************************"
37 }