increase dvbapp PR.
[vuplus_openembedded] / recipes / webif / webif_svn.bb
1 DESCRIPTION = "Web interface"
2 LICENSE = "GPL"
3
4 PV = "0.0.3+svnr${SRCPV}"
5 SRCREV = "4737"
6
7 SRC_URI = "svn://x-wrt.googlecode.com/svn;module=trunk;proto=http"
8
9 S = "${WORKDIR}/trunk"
10
11 do_compile() {
12         cd ${S}/package/webif/ 
13         ${CC} ${CFLAGS} \
14                 -D_METAPACK \
15                 -I${STAGING_INCDIR} -include endian.h \
16                 ${LDFLAGS} \
17                 -o ${S}/webifmetabin \
18                 src/int2human/main.c src/int2human/human_readable.c \
19                 src/wepkeygen/keygen.c src/wepkeygen/md5.c \
20                 src/webif-page.c src/bstrip.c src/webifmetabin.c
21 }
22
23 do_install() {
24         install -d ${D}${bindir}
25         install -m 0755 ${S}/webifmetabin ${D}${bindir}/
26
27         install -d ${D}${sysconfdir}    
28         cp -dPr ${S}/package/webif/files/etc/* ${D}${sysconfdir}/
29
30         install -d ${D}${libdir}
31         cp -dPr ${S}/package/webif/files/usr/lib/* ${D}${libdir}/
32
33         find ${D} -name ".svn" | xargs rm -r || true
34 }
35
36
37 RDEPENDS_${PN} = "haserl ${IPKG_VARIANT} cron"