Merge commit 'opendreambox/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / vtun / vtun_2.6.bb
1 DESCRIPTION = "Virtual Tunnels over TCP/IP networks with traffic shaping, compression and encryption."
2 HOMEPAGE = "http://vtun.sourceforge.net/"
3 SECTION = "console/network"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "zlib lzo"
7 PR = "r1"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/vtun/vtun-${PV}.tar.gz \
10         file://init \
11         file://makefile.in-ldflags.patch;patch=1;pnum=0"
12
13 S = "${WORKDIR}/vtun"
14
15 inherit autotools
16
17 do_configure() {
18         export BLOWFISH_HDR_DIR=${STAGING_INCDIR}/openssl
19         oe_runconf --with-lzo-headers=${STAGING_INCDIR} --with-ssl-headers=${STAGING_INCDIR}/openssl
20 }
21
22 do_install() {
23         oe_runmake INSTALL_OWNER="" DESTDIR=${D} install
24         install -d ${D}${sysconfdir}/init.d/
25         install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/vtund
26         install ${S}/scripts/vtund-start.conf ${D}${sysconfdir}
27 }
28
29 CONFFILES_${PN}_nylon = "${sysconfdir}/vtund-start.conf ${sysconfdir}/vtund.conf"