change usbtunerhelper src_uri.
[vuplus_openembedded] / recipes / vnc / tightvnc_1.3.9.bb
1 DESCRIPTION-${PN}-viewer = "A lightweight VNC viewer"
2 HOMEPAGE = "http://www.tightvnc.com/"
3 DEPENDS = "virtual/libx11 zlib libxmu libxaw"
4 LICENSE = "GPL"
5
6 PR = "r2"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/vnc-tight/${PN}-${PV}_unixsrc.tar.gz \
9            file://Makefile \
10            file://Vncviewer"
11
12 S = "${WORKDIR}/vnc_unixsrc/vncviewer/"
13
14 PACKAGES = "${PN}-viewer-dbg ${PN}-viewer"
15 FILES_${PN}-viewer-dbg = "${bindir}/.debug"
16 FILES_${PN}-viewer = "${bindir}/${PN}viewer ${sysconfdir}"
17
18 do_compile () {
19         install ${WORKDIR}/Makefile ${S}
20         oe_runmake
21 }
22
23 do_install () {
24         install -d ${D}${bindir}
25         install ${PN}viewer ${D}${bindir}
26         install -d ${D}${sysconfdir}/X11/app-defaults
27         install -m 644 ${WORKDIR}/Vncviewer ${D}${sysconfdir}/X11/app-defaults/Vncviewer
28 }
29
30 pkg_postinst_${PN}-viewer () {
31         update-alternatives --install ${bindir}/vncviewer vncviewer tightvncviewer 100
32 }
33
34
35 pkg_prerm_${PN}-viewer () {
36         update-alternatives --remove ${bindir}/vncviewer vncviewer tightvncviewer 100
37 }