Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / vnc / libvncserver_0.9.bb
1 DESCRIPTION = "A library to support implementations of RDP/VNC servers"
2 AUTHOR = "Johannes Schindelin <dscho@users.sourceforge.net>"
3 HOMEPAGE = "http://sourceforge.net/projects/libvncserver"
4 SECTION = "libs"
5 PRIORITY = "optional"
6 LICENSE = "GPLv2"
7 DEPENDS = "virtual/libsdl virtual/libx11 zlib jpeg libxext"
8 PROVIDES = "x11vnc"
9 PR = "r2"
10
11 SRC_URI = "${SOURCEFORGE_MIRROR}/libvncserver/LibVNCServer-${PV}.tar.gz"
12 S = "${WORKDIR}/LibVNCServer-${PV}"
13
14 inherit autotools
15
16 do_stage() {
17     autotools_stage_all
18 }
19
20 do_install_append() {
21         install -d ${D}${bindir}
22         install -m 0755 examples/storepasswd ${D}${bindir}
23         install -d ${D}${datadir}/fbvncserver/classes
24         install -m 0644 classes/index.vnc ${D}${datadir}/fbvncserver/classes/
25         install -m 0644 classes/VncViewer.jar ${D}${datadir}/fbvncserver/classes/
26 }
27
28 PACKAGES =+ "x11vnc libvncserver-storepasswd libvncserver-javaapplet"
29 FILES_x11vnc = "${bindir}/x11vnc ${bindir}/LinuxVNC"
30 FILES_libvncserver-storepasswd = "${bindir}/storepasswd"
31 FILES_libvncserver-javaapplet = "${datadir}/fbvncserver/classes/index.vnc \
32                                  ${datadir}/fbvncserver/classes/VncViewer.jar"