Merge branch 'opendreambox' of git://git.opendreambox.org/git/openembedded into opend...
[vuplus_openembedded] / recipes / vlc / vlc_0.9.2.bb
1 DESCRIPTION = "Video player and streamer - davinci edition"
2 HOMEPAGE = "http://www.videolan.org"
3 LICENSE = "GPL"
4 PRIORITY = "optional"
5 SECTION = "multimedia"
6
7 PR = "r2"
8
9 DEPENDS = "libtool hal gettext libgcrypt schroedinger libsdl-x11 qt4-x11-free dbus libxml2 gnutls tremor faad2 ffmpeg flac \
10            ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad libid3tag liba52 mpeg2dec', d)}"
11
12 SRC_URI = "http://videolan.mirror.technotop.nl/vlc/0.9.2/vlc-${PV}.tar.bz2"
13
14 inherit autotools
15
16 EXTRA_OECONF = "\
17         --enable-libtool \
18         --with-contrib \
19         --disable-dvdread \
20         --disable-wxwidgets \
21         --enable-x11 --enable-xvideo \ 
22         --disable-screen --disable-caca \
23         --enable-httpd --enable-vlm \
24         --enable-freetype \
25         --enable-sdl \ 
26         --enable-png \
27         --enable-live555 --enable-tremor \
28         --enable-v4l2 --enable-v4l --disable-aa --enable-wma --disable-faad \
29         --enable-dbus \
30         --enable-hal \  
31         --without-contrib \
32         ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}/moc4 \
33         ac_cv_path_RCC=${STAGING_BINDIR_NATIVE}/rcc4 \
34         ac_cv_path_UIC=${STAGING_BINDIR_NATIVE}/uic4 \
35 "
36
37
38 do_configure() {
39         cp ${STAGING_DATADIR}/aclocal/libgcrypt.m4 ${S}/m4/ 
40         ./bootstrap     
41         gnu-configize --force
42         libtoolize --force
43         #autoreconf --force -i
44         cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/
45         oe_runconf
46         rm config.log
47         sed -i -e s:-L/usr/lib:-L${STAGING_LIBDIR}/:g vlc-config
48         sed -i -e s:'$(MOC) $(DEFS) $(CPPFLAGS)':'$(MOC) $(DEFS)'\ -I${S}/include\ -DSYS_LINUX:g ${S}/modules/gui/qt4/Makefile
49 }
50
51 do_stage() {
52         autotools_stage_all
53 }
54
55
56 FILES_${PN} += "${bindir}/vlc \
57         ${datadir}/applications \
58         ${datadir}/vlc/ \
59         "
60
61 FILES_${PN}-dbg += "${libdir}/vlc/*/.debug"