dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / visiscript / visiscript_0.4.3.bb
1 DESCRIPTION = "VisiScript is a simple graphical frontend for \
2 scripting languages like minscript, Python,Ruby, Perl or others. \
3 VisiScript runs on the Qtopia desktop environment of the Zaurus."
4 SECTION = "opie/applications"
5 DEPENDS = "qscintilla"
6 LICENSE = "GPL"
7 APPNAME = "visiscript"
8 APPTYPE = "binary"
9 APPDESKTOP = "${S}"
10
11 BROKEN = "1"
12
13 SRC_URI = "http://www.mneuroth.de/privat/zaurus/visiscript_src_${PV}.tar.gz \
14            file://qptrlist.h file://qcleanuphandler.h"
15
16 S = "${WORKDIR}/visiscript-${PV}"
17
18 inherit opie
19
20 QMAKE_PROFILES = "zvisiscript.pro"
21 PARALLEL_MAKE = ""
22
23 EXTRA_QMAKEVARS_POST += "LIBS-=../qscintilla-1.65-gpl-1.6/qt/libqscintilla.a LIBS+=-lqscintilla LIBS+=-ldl"
24 export OE_QMAKE_LINK="${CXX}"
25
26 do_compile_prepend() {
27         install -m 0644 ${WORKDIR}/*.h ${S}
28 }
29
30 do_install() {
31         install -d ${D}${palmtopdir}/pics/
32         install -m 0644 Visiscript.png ${D}${palmtopdir}/pics
33 }
34
35 #FIXME: package help and translation