util-linux-ng: split out libs to avoid collision with e2fsprog-libs
[vuplus_openembedded] / recipes / util-linux-ng / util-linux-ng_2.15.bb
1 require util-linux-ng.inc
2
3 PR = "r2"
4
5 SRC_URI += "file://fix-make-c.patch;patch=1 \
6             file://optional-uuid.patch;patch=1 \
7 "
8
9 FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/util-linux-ng-2.15', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
10
11 LDFLAGS_append = " -luuid"
12 LDFLAGS_append_libc-uclibc = " -luuid -lintl"
13
14 do_compile_prepend() {
15         sed -i /am__append_1/d ${S}/libs/blkid/src/Makefile
16 }