change usbtunerhelper src_uri.
[vuplus_openembedded] / recipes / upslug / upslug-native_1.0.bb
1 # This package builds the 'upslug' binary upload/flash tool
2 # for the NSLU2.  It is not useful for anything else.
3 PR = "r1"
4 DESCRIPTION = "NSLU2 binary upload tool"
5 HOMEPAGE = "http://www.nslu2-linux.org/wiki/Main/UpSlug"
6 SECTION = "console/network"
7 PRIORITY = "optional"
8 LICENSE = "GPLv2"
9 COMPATIBLE_MACHINE = "nslu2"
10
11 SRC_TAG = "UPSLUG_${@'_'.join(bb.data.getVar('PV',d,1).split('.'))}"
12 SRC_URI = "cvs://anonymous@nslu.cvs.sourceforge.net/cvsroot/nslu;method=pserver;module=upslug;tag=${SRC_TAG}"
13 # For testing use this (tags and other changes take a day to
14 # propogate on sourceforge).  Change 'jbowler' to your login name!
15 #SRC_URI = "cvs://jbowler@cvs.sourceforge.net/cvsroot/nslu;method=ext;rsh=ssh;tag=${SRC_TAG};module=upslug"
16
17 inherit native
18
19 S = "${WORKDIR}/upslug"
20
21 # Dumb compile script
22 do_compile() {
23         oe_runmake "CC=${CC}" "CFLAGS=${CFLAGS}"
24 }
25
26 do_stage() {
27         oe_runmake "DESTDIR=${STAGING_BINDIR}" install
28 }