support manual-nameserver.
[vuplus_openembedded] / recipes / uicmoc / uicmoc3-native_3.3.5.bb
1 DESCRIPTION = "User Interface Generator and Meta Object Compiler (moc) for Qt(E) 3.x"
2 HOMEPAGE = "http://www.trolltech.com"
3 SECTION = "devel"
4 PRIORITY = "optional"
5 LICENSE = "GPL QPL"
6 DEPENDS = "qmake-native"
7 PR = "r3"
8
9 SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-free-${PV}.tar.bz2 \
10            file://no-examples.patch;patch=1 \
11            file://64bit-cleanup.patch;patch=1"
12 S = "${WORKDIR}/qt-embedded-free-${PV}"
13
14 inherit native qmake_base qt3e
15
16 export QTDIR = "${S}"
17 export OE_QMAKE_LINK="${CXX}"
18 CXXFLAGS += " -DQWS"
19
20 QT_CONFIG_FLAGS = "-release -static -depths 8,16 -qt-zlib -no-nas-sound \
21                    -no-sm -no-libjpeg -no-libmng -no-gif -no-xshape -no-xinerama \
22                    -no-xcursor -no-xrandr -no-xrender -no-xft -no-tablet \
23                    -no-xkb -no-dlopen-opengl -no-freetype -no-thread \
24                    -no-nis -no-cups -prefix ${prefix} \
25                    -xplatform ${OE_QMAKE_PLATFORM} \
26                    -platform ${OE_QMAKE_PLATFORM}"
27
28 do_configure() {
29     oe_qmake_mkspecs
30     echo "yes" | ./configure ${QT_CONFIG_FLAGS}
31 }
32
33 do_compile() {
34     oe_runmake symlinks  || die "Can't symlink include files"
35     oe_runmake src-moc   || die "Building moc failed"
36     oe_runmake sub-tools || die "Building tools failed"
37 }
38
39 do_stage() {
40         install -d ${OE_QMAKE_INCDIR_QT}
41         install -d ${OE_QMAKE_LIBDIR_QT}
42
43         install -m 0755 bin/moc ${OE_QMAKE_MOC}
44         install -m 0755 bin/uic ${OE_QMAKE_UIC}
45         install -m 0655 lib/*.a ${OE_QMAKE_LIBDIR_QT}
46
47         for f in include/*.h
48         do
49                 install -m 0644 $f ${OE_QMAKE_INCDIR_QT}/
50         done
51 }