rename packages/ to recipes/ per earlier agreement
[vuplus_openembedded] / recipes / uicmoc / uicmoc-native_2.3.10.bb
1 DESCRIPTION = "User Interface Generator and Meta Object Compiler (moc) for Qt(E) 2.x"
2 HOMEPAGE = "http://www.trolltech.com"
3 SECTION = "devel"
4 PRIORITY = "optional"
5 LICENSE = "GPL QPL"
6 PR = "r4"
7
8 SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz \
9            file://fix-makefile.patch;patch=1 \
10            file://gcc3_4.patch;patch=1 \
11            file://gcc4.patch;patch=1 \
12            file://gcc4_1.patch;patch=1 \
13            file://64bit-cleanup.patch;patch=1 \
14            file://kernel-asm-page.patch;patch=1"
15 S = "${WORKDIR}/qt-${PV}"
16
17 inherit native qmake_base
18
19 export QTDIR = "${S}"
20 EXTRA_OEMAKE = 'SYSCONF_CXX="${CXX}" SYSCONF_LINK="${CXX}"'
21 CXXFLAGS += " -DQWS"
22
23 QT_CONFIG_FLAGS = "-depths 8,16 -no-qvfb -no-g++-exceptions -no-jpeg -no-mng \
24                    -qt-zlib -qt-libpng -no-xft -no-xkb -no-vnc -no-sm \
25                    -no-opengl -static -qconfig oe"
26
27 do_configure() {
28     touch src/tools/qconfig-oe.h
29     echo "#define QT_NO_FREETYPE" >> src/tools/qconfig-oe.h
30     echo yes | ./configure ${QT_CONFIG_FLAGS} || die "Configuring qt failed"
31 }
32
33 do_compile() {
34     oe_runmake symlinks   || die "Can't symlink include files"
35     oe_runmake -C src/moc || die "Building moc failed"
36
37     cp src/moc/moc bin/
38
39     oe_runmake -C src                 || die "Building libqt.a failed"
40     oe_runmake -C tools/designer/util || die "Building libqutil.a failed"
41     oe_runmake -C tools/designer/uic  || die "Building uic failed"
42     oe_runmake -C tools/qvfb          || die "Building qvfb failed"
43     oe_runmake -C tools/makeqpf       || die "Building makeqpf failed"
44 }
45
46 do_stage() {
47     install -m 0755 bin/moc ${STAGING_BINDIR}
48     install -m 0755 bin/uic ${STAGING_BINDIR}
49     install -m 0755 tools/makeqpf/makeqpf ${STAGING_BINDIR}
50 }