Merge commit 'origin/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / uclibc / uclibc_0.9.30.2.bb
1 # UCLIBC_BASE should be the latest released revision of uclibc (that way
2 # the config files will typically be correct!)  uclibc-cvs takes precedence
3 # over uclibc-${UCLIBC_BASE}, if a config file in uclibc-cvs is out of date
4 # try removing it
5 #
6 # UCLIBC_BASE can be set in a distro file, but whether this works depends
7 # on whether the base patches apply to the selected (SRCDATE) svn release.
8 #
9 UCLIBC_BASE ?= "0.9.30.2"
10
11 require uclibc.inc
12 PR = "${INC_PR}.0"
13
14 PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
15
16 SRC_URI += "file://uClibc.machine file://uClibc.distro \
17             file://pthread_atfork.patch;patch=1 \
18             file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch;patch=1 \
19             file://installfix.patch;patch=1 \
20             file://o_cloexec.patch;patch=1 \
21             file://uclibc_fix_mips_crt.patch;patch=1 \
22            "
23 SRC_URI[uClibc-0.9.30.2.md5sum] = "e759ec855500082ac3e671dd6cacfdb0"
24 SRC_URI[uClibc-0.9.30.2.sha256sum] = "ab6e92c91e2f8fad182d3b624b87d6cbf53072678d8fc31ad73e6abd3c852473"
25
26 #recent versions uclibc require real kernel headers
27 PACKAGE_ARCH = "${MACHINE_ARCH}"
28
29 #as stated above, uclibc needs real kernel-headers
30 #however: we can't depend on virtual/kernel when nptl hits due to depends deadlocking ....
31 KERNEL_SOURCE = "${STAGING_DIR_HOST}/${exec_prefix}"
32
33 S = "${WORKDIR}/uClibc-${UCLIBC_BASE}"