Merge commit 'opendreambox/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / uclibc / uclibc-initial_nptl.bb
1 SECTION = "base"
2 require uclibc_nptl.bb
3
4 DEPENDS = "linux-libc-headers ncurses-native virtual/${TARGET_PREFIX}gcc-initial"
5 PROVIDES = "virtual/${TARGET_PREFIX}libc-initial"
6 PACKAGES = ""
7
8 do_install() {
9         # Install initial headers into the cross dir
10         make V=1 PREFIX=${D} DEVEL_PREFIX=${prefix}/ RUNTIME_PREFIX=/ \
11                 install_headers
12         #ln -sf include ${CROSS_DIR}/${TARGET_SYS}/sys-include
13
14         # This conflicts with the c++ version of this header
15         rm -f ${D}${includedir}/bits/atomicity.h
16         install -d ${D}${libdir}/
17         install -m 644 lib/crt[1in].o ${D}${libdir}/
18         install -m 644 lib/libc.so ${D}${libdir}/
19 }
20
21 do_compile () {
22         make V=1 PREFIX=${D} DEVEL_PREFIX=${prefix}/ RUNTIME_PREFIX=/ \
23                 lib/crt1.o lib/crti.o lib/crtn.o
24         ${CC} -nostdlib -nostartfiles -shared -x c /dev/null \
25                 -o lib/libc.so
26 }