Merge commit 'opendreambox/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / uclibc / uclibc-initial_0.9.30.bb
1 SECTION = "base"
2 require uclibc_${PV}.bb
3
4 DEPENDS = "linux-libc-headers ncurses-native virtual/${TARGET_PREFIX}gcc-initial"
5 PROVIDES = "virtual/${TARGET_PREFIX}libc-initial"
6 PACKAGES = ""
7
8 do_install() {
9         # Install initial headers into the cross dir
10         make PREFIX=${D} DEVEL_PREFIX=${prefix}/ RUNTIME_PREFIX=/ \
11                 install_headers
12
13         #ln -sf include ${CROSS_DIR}/${TARGET_SYS}/sys-include
14
15         # This conflicts with the c++ version of this header
16         rm -f ${D}${includedir}/bits/atomicity.h
17         install -d ${D}${libdir}/
18         install -m 644 lib/crt[1in].o ${D}${libdir}/
19         install -m 644 lib/libc.so ${D}${libdir}/
20 }
21
22 do_compile () {
23         make PREFIX=${D} DEVEL_PREFIX=${prefix}/ RUNTIME_PREFIX=/ \
24                 lib/crt1.o lib/crti.o lib/crtn.o
25         ${CC} -nostdlib -nostartfiles -shared -x c /dev/null \
26                 -o lib/libc.so
27 }