update driver
[vuplus_openembedded] / recipes / u-boot / u-boot_2009.03.bb
1 PR = "r2"
2 require u-boot.inc
3
4 DEFAULT_PREFERENCE = "-1"
5 DEFAULT_PREFERENCE_hipox = "1"
6
7 SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 "
8
9 SRC_URI_append_hipox = "file://00-hipox.patch;patch=1 \
10         file://01-hipox-fix-gmac-reset.patch;patch=1 \
11         file://02-hipox-enable-mmu.patch;patch=1 \
12         file://03-hipox-direct-switch.patch;patch=1 \
13         file://04-hipox-env.patch;patch=1 \
14 "
15
16 TARGET_LDFLAGS = ""
17
18 UBOOT_MACHINE_hipox  = "hipox_config"
19
20 inherit base
21
22 do_compile () {
23         oe_runmake ${UBOOT_MACHINE}
24         oe_runmake all
25 }