Merge branch 'opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / u-boot / u-boot_1.1.2.bb
1 PR = "r3"
2 require u-boot.inc
3
4 SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
5            file://arm_flags.patch;patch=1 "
6 # Override whole URI fr Neon since Neon patch is incompatible with arm_flags patch.
7 SRC_URI_bd-neon = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
8                    file://u-boot-1.1.2-neon.patch;patch=1"
9 SRC_URI_append_vibren = "ftp://bec-systems.com/pub/pxa255_idp/u-boot/uboot_pxa255-idp_2005-03-23.patch;patch=1"
10 SRC_URI_append_mnci   = "file://mnci.patch;patch=1 \
11                          file://mnci-jffs2.patch;patch=1 \
12                          file://cmd-arm-linux.patch;patch=1 \
13                          file://command-names.patch;patch=1"
14
15 SRC_URI_append_magicbox  = "file://u-boot-emetec.patch;patch=1 "
16
17
18 # TODO: SRC_URI_append_rt3000
19
20 TARGET_LDFLAGS = ""
21
22 UBOOT_MACHINE_mnci   = "mnci_config"
23 UBOOT_MACHINE_vibren = "pxa255_idp_config"
24 UBOOT_MACHINE_magicbox = "EMETEC405_config"
25
26 inherit base
27
28 do_compile () {
29         oe_runmake ${UBOOT_MACHINE}
30         oe_runmake all
31 }
32
33 #########################################################
34
35 RDEPENDS_append_mnci = " hwctrl"
36
37 FILES_${PN}_mnci = "/tmp/${UBOOT_IMAGE}"
38
39 do_configure_prepend_bd-neon () {
40         chmod +x ${S}/Configure
41 }
42
43 do_install_openmn() {
44         install -d ${D}/tmp
45         install ${S}/u-boot.bin ${D}/tmp/${UBOOT_IMAGE}
46 }
47
48 pkg_postinst_mnci() {
49 ldconfig
50 A=/tmp/bootargs
51 hwctrl kernel_conf_get bootargs >$A
52 cp /tmp/${UBOOT_IMAGE} /dev/mtdblock/0
53 rm /tmp/${UBOOT_IMAGE}
54 hwctrl kernel_conf_set bootargs "`cat $A`"
55 cat /dev/mtdblock/0 >/dev/null
56 exit 0
57 }