Merge commit 'opendreambox/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / tuxbox / tuxbox-stream.bb
1 DEPENDS = "dreambox-dvbincludes tuxbox-libs"
2 RDEPENDS = "libtuxbox-mpegtools0"
3 DESCRIPTION = "tuxbox net streaming tools"
4 MAINTAINER = "Felix Domke <tmbinc@elitdvb.net>"
5
6 SRC_URI = "cvs://anoncvs@cvs.tuxbox.org/cvs/tuxbox;module=apps/dvb/tools/stream;method=ext \
7            file://acinclude.m4 \
8            file://enable_transform.diff;patch=1;pnum=1 \
9            file://udpstreampes_build_fix.diff;patch=1;pnum=1 \
10            file://add_configfiles.diff;patch=1;pnum=1"
11
12 SRCDATE = "20050802"
13 S = "${WORKDIR}/stream"
14 PV = "1.0+${SRCDATE}"
15 PR = "r2"
16
17 inherit autotools pkgconfig
18
19 bindir = "/usr/bin"
20 sbindir = "/usr/sbin"
21
22 EXTRA_OECONF = "--with-target=native --with-boxtype=${MACHINE}"
23
24 CFLAGS_append = " -DHAVE_DREAMBOX_HARDWARE"
25
26 do_configure_prepend() {
27         install ${WORKDIR}/acinclude.m4 ${S}/acinclude.m4
28 }
29
30 do_install_append() {
31         ln -s streampes ${D}/usr/sbin/streames
32 }