increase dvbapp PR.
[vuplus_openembedded] / recipes / tuxbox / tuxbox-common.bb
1 DESCRIPTION = "Tuxbox common files"
2 LICENSE = "GPL"
3 MAINTAINER = "Felix Domke <tmbinc@elitdvb.net>"
4
5 PN = "tuxbox-common"
6 PR = "r4"
7
8 SRC_REV = "8ef7a7f5f5df5f77197ad279e24b0dc454b8210b"
9
10 SRC_URI = "git://git.code.sf.net/p/tuxbox-cvs/cdk;protocol=git;tag=${SRC_REV} \
11         http://dreamboxupdate.com/download/opendreambox/tuxbox-common-r11.tar.gz \
12         file://satellites_20130124.patch;patch=1;pnum=1 \
13 "
14
15 FILES_${PN} = "/"
16
17 #S = "${WORKDIR}/tuxbox-common-r11 "
18 S = "${WORKDIR}/git/root_dream/share"
19
20 TRANSPONDER_LISTS = "satellites.xml terrestrial.xml"
21
22 #enigma1 need a cables.xml
23 TRANSPONDER_LISTS_append_dm7020 = " cables.xml"
24 TRANSPONDER_LISTS_append_dm500plus = " cables.xml"
25 TRANSPONDER_LISTS_append_dm600pvr = " cables.xml"
26
27 do_install() {
28         install -d ${D}/etc/init.d
29         install -d ${D}/etc/rcS.d
30         install -d ${D}/etc/tuxbox/
31         install -d ${D}/usr/share/tuxbox
32         install -m 0644 ${WORKDIR}/tuxbox-common-r11/scart.conf ${D}/etc/tuxbox/scart.conf
33
34         install -m 0644 ${WORKDIR}/tuxbox-common-r11/timezone.xml ${D}/etc/tuxbox/timezone.xml
35         ln -sf /etc/tuxbox/timezone.xml ${D}/etc/
36
37         ln -sf /usr/share ${D}/share
38
39 #               install -m 0644 ${WORKDIR}/tuxbox/$i ${D}/etc/tuxbox/$i
40         for i in ${TRANSPONDER_LISTS}; do
41                 install -m 0644 ${S}/tuxbox/$i ${D}/etc/tuxbox/$i
42                 ln -sf /etc/tuxbox/$i ${D}/etc/;
43                 ln -sf /etc/tuxbox/$i ${D}/usr/share/;
44                 ln -sf /etc/tuxbox/$i ${D}/usr/share/tuxbox/;
45         done;
46 }