Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / recipes / ttyrec / ttyrec_1.0.8.bb
1 #! /bin/sh
2 #
3 # Copyright Matthias Hentges <devel@hentges.net> (c) 2007
4 # License: MIT (see http://www.opensource.org/licenses/mit-license.php 
5 #               for a copy of the license)
6 #
7 # Filename: ttyrec_1.0.8.bb
8 # Date: 20070403 (YMD)
9
10 DESCRIPTION = "ttyrec is a tty recorder. Recorded data can be played back with the included ttyplay command."
11 HOMEPAGE = "http://0xcc.net/ttyrec/index.html.en"
12
13 ######################################################################################
14
15 PR = "r0"
16
17 ######################################################################################
18
19 SRC_URI = "http://0xcc.net/ttyrec/${PN}-${PV}.tar.gz \
20            file://Makefile.patch;patch=1"
21
22 ######################################################################################
23
24 inherit autotools
25
26 ######################################################################################
27
28 S = "${WORKDIR}/${PN}-${PV}"
29
30 ######################################################################################
31
32 do_install() {
33         install -d ${D}/usr/bin
34         install -d ${D}/usr/share/man/man1 
35         
36         for binary in ttyrec ttyplay ttytime
37         do
38                 install -m 0755 ${S}/${binary} ${D}/usr/bin/
39                 install -m 0644 ${S}/${binary}.1 ${D}/usr/share/man/man1
40         done
41 }