Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / ttf-fonts / ttf-sazanami_20040629.bb
1 require ttf.inc
2
3 DESCRIPTION = "Sazanami Gothic/Mincho Japanese TrueType fonts"
4 DESCRIPTION_ttf-sazanami-gothic = "Sazanami Gothic Japanese TrueType font"
5 DESCRIPTION_ttf-sazanami-mincho = "Sazanami Mincho Japanese TrueType font"
6 AUTHOR = "Electronic Font Open Laboratory (/efont/)"
7 HOMEPAGE = "http://sourceforge.jp/projects/efont/"
8 LICENSE = "${PN}"
9 SRC_DISTRIBUTE_LICENSES += "${PN}"
10 RPROVIDES = "virtual-japanese-font"
11 PR = "r4"
12
13 SRC_URI = "http://osdn.dl.sourceforge.jp/efont/10087/sazanami-20040629.tar.bz2"
14 S = "${WORKDIR}/sazanami-20040629"
15
16 PACKAGES = "${PN}-dbg ttf-sazanami-gothic ttf-sazanami-mincho"
17 RRECOMMENDS_${PN}-dbg = ""
18 FILES_ttf-sazanami-gothic = "${datadir}/fonts/truetype/sazanami-gothic.ttf \
19                              ${datadir}/doc/ttf-sazanami-gothic/README"
20 FILES_ttf-sazanami-mincho = "${datadir}/fonts/truetype/sazanami-mincho.ttf \
21                              ${datadir}/doc/ttf-sazanami-mincho/README"
22
23 do_install_append() {
24         # README contains the redistribution license
25         install -d ${D}${datadir}/doc/
26         install -d ${D}${datadir}/doc/ttf-sazanami-gothic
27         install -d ${D}${datadir}/doc/ttf-sazanami-mincho
28         install -m 0644 ${S}/README ${D}${datadir}/doc/ttf-sazanami-gothic
29         install -m 0644 ${S}/README ${D}${datadir}/doc/ttf-sazanami-mincho
30 }