dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / tofrodos / tofrodos_1.7.8.bb
1 DESCRIPTION = "Tofrodos is a text file conversion utility that converts ASCII files between the MSDOS and unix format"
2 LICENSE = "GPLv2"
3
4 SRC_URI = "http://tofrodos.sourceforge.net/download/tofrodos-${PV}.tar.gz \
5            file://cross.patch;patch=1;pnum=2"
6
7 S = "${WORKDIR}/${PN}/src"
8
9 do_install() {
10         install -d ${D}/usr/man/man1
11         install -d ${D}/${bindir}
12         oe_runmake DESTDIR=${D} install
13         cd ${D}/${bindir}
14 }
15
16 FILES_${PN} = "${bindir}/fromdos"
17
18 pkg_postinst_${PN} () {
19 #!/bin/sh
20 for app in dos2unix unix2dos todos ; do
21     update-alternatives --install ${bindir}/$app $app fromdos 100
22 done
23 }
24
25 pkg_prerm_${PN} () {
26  #!/bin/sh
27 for app in dos2unix unix2dos todos ; do
28    update-alternatives --remove $app fromdos
29 done
30 }
31
32
33
34
35
36