increase dvbapp PR.
[vuplus_openembedded] / recipes / ti / ti-codec-engine_2.24.01.bb
1 DESCRIPTION = "Codec Engine 2.24.01 for TI ARM/DSP processors"
2
3 require ti-paths.inc
4
5 # compile time dependencies
6 DEPENDS = "ti-framework-components ti-xdais-native ti-xdctools-native ti-cgt6x-native"
7
8 DEPENDS_append_dm6446   = " ti-dspbios-native ti-linuxutils ti-dsplink-module"
9 DEPENDS_append_omap3    = " ti-dspbios-native ti-linuxutils ti-dsplink-module"
10
11 # tconf from xdctools dislikes '.' in pwd :/
12 PR = "r7"
13 PV = "2_24_01"
14
15 SRC_URI = "http://install.source.dir.local/codec_engine_2_24_01.tar.gz "
16
17 # Set the source directory
18 S = "${WORKDIR}/codec_engine_2_24_01"
19
20 # Define Device variable
21 DEVICES_dm6446  ?= "DM6446"
22 DEVICES_omap3   ?= "OMAP3530"
23 DEVICES_dm355   ?= "DM355"
24
25 #define PROGRAM variables
26 PROGRAMS        ?= "APP_CLIENT DSP_SERVER"
27 PROGRAMS_dm355   = "APP_LOCAL"
28
29 LINK_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-dsplink-module/packages"
30 CGT6x_DIR = "${STAGING_DIR_NATIVE}/ti-cgt6x-native"
31 XDCTOOLS_DIR = "${STAGING_DIR_NATIVE}/ti-xdctools-native"
32 CE_INSTALL_DIR = "${S}"
33
34 do_compile () {
35
36         sed -i  \
37                 -e s:arm-none-linux-gnueabi-:${TARGET_PREFIX}:g \
38                 ${S}/examples/xdcpaths.mak
39
40         for i in codecs extensions servers apps ; do
41                 cd ${S}/examples/ti/sdo/ce/examples/$i
42                 make DEVICES="${DEVICES}" \
43                      GPPOS="${GPPOS}" \
44                      PROGRAMS="${PROGRAMS}" \
45                      CE_INSTALL_DIR="${CE_INSTALL_DIR}" \
46                      XDC_INSTALL_DIR="${XDCTOOLS_DIR}" \
47                      BIOS_INSTALL_DIR="${BIOS_INSTALL_DIR}"\
48                      DSPLINK_INSTALL_DIR="${LINK_INSTALL_DIR}" \
49                      XDAIS_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
50                      FC_INSTALL_DIR="${FC_INSTALL_DIR}" \
51                      CMEM_INSTALL_DIR="${CMEM_INSTALL_DIR}" \
52                      LPM_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
53                      EDMA3_INSTALL_DIR="${CE_INSTALL_DIR}/cetools" \
54                      CGTOOLS_V5T="${CROSS_DIR}"\
55                      CGTOOLS_C64P="${CGT6x_DIR}" \
56                      clean all
57         done
58 }
59
60 do_install() {
61         install -d ${D}/${installdir}/codec-engine-apps
62         cp ${S}/examples/apps/system_files/${DEVICES}/loadmodules.sh ${D}/${installdir}/codec-engine-apps
63         sed -i 's/insmod/modprobe/g' ${D}/${installdir}/codec-engine-apps/loadmodules.sh
64
65         cd ${S}/examples/ti/sdo/ce/examples
66
67         for i in $(find . -name "*.xv5T"); do
68                 install -d ${D}/${installdir}/codec-engine-apps/`dirname ${i} | cut -f3 -d /`
69                 install ${i} ${D}/${installdir}/codec-engine-apps/`dirname ${i} | cut -f3 -d /`
70
71         for j in $(find . -name "*.x64P"); do
72                 install ${j} ${D}/${installdir}/codec-engine-apps/`dirname ${i} | cut -f3 -d /`
73         done
74
75     done
76 }
77
78
79 # stage tree - other packages may need this
80 do_stage() {
81     install -d ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/${PN}
82     cp -pPrf ${S}/* ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/${PN}/ 
83 }
84
85 PACKAGE_ARCH = "${MACHINE_ARCH}"
86 INHIBIT_PACKAGE_STRIP = "1"
87 PACKAGES += "ti-codec-engine-apps"
88 FILES_ti-codec-engine-apps = "${installdir}/codec-engine-apps/*"
89 INSANE_SKIP_ti-codec-engine-apps = True
90