increase dvbapp PR.
[vuplus_openembedded] / recipes / ti / bitblit_svn.bb
1 DESCRIPTION = "Low level 2D blitting/blending graphics acceleration services support on DM6446, OMAP3530 and OMAP-L137."
2
3 require ti-paths.inc
4
5 inherit autotools
6
7 DEPENDS = "ti-codec-engine ti-dmai"
8
9 # Fetch source from svn repo
10 SRCREV = "2"
11 SRC_URI = "svn://gforge.ti.com/svn/${PN};module=trunk;proto=https;user=anonymous;pswd='' \
12            file://recent-linux.diff;patch=1 \
13 "
14
15 # Again, no '.' in PWD allowed :(
16 PV = "0+svnr${SRCPV}"
17 PR = "r1"
18
19 S = "${WORKDIR}/trunk/bitblit"
20
21 export LINUXLIBS_INSTALL_DIR="${STAGING_DIR_HOST}/usr"
22 export EXEC_DIR = "${D}${datadir}/ti/bitblit/"
23
24 CPPFLAGS_append                         = " -DPlatform_${PLATFORM}"
25
26 PACKAGE_ARCH = "${MACHINE_ARCH}"
27
28 do_compile() {
29         oe_runmake -e all
30 }
31
32 do_install() {
33         oe_runmake -e install
34 }