Merge commit 'opendreambox/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / telepathy / telepathy-glib_0.5.10.bb
1 DESCRIPTION = "Telepathy framework - GLib library"
2 HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
3 DEPENDS = "glib-2.0 dbus python-native dbus-native"
4 LICENSE = "LGPL"
5
6 SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-glib/${P}.tar.gz "
7
8 inherit autotools pkgconfig
9
10 FILES_${PN} += "${datadir}/telepathy \
11                 ${datadir}/dbus-1"
12
13 do_stage() {
14         #
15         # copied autotools_stage_all because telepathy-glib has one lib only built as static
16         # so it can not be oe_libinstalled
17         #
18         rm -rf ${STAGE_TEMP}
19         mkdir -p ${STAGE_TEMP}
20         oe_runmake DESTDIR="${STAGE_TEMP}" install
21         if [ -d ${STAGE_TEMP}/${includedir} ]; then
22                 cp -fpPR ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}
23         fi
24         if [ -d ${STAGE_TEMP}/${libdir} ]
25         then
26                 for i in ${STAGE_TEMP}/${libdir}/*.la
27                 do
28                         if [ ! -f "$i" ]; then
29                                 cp -fpPR ${STAGE_TEMP}/${libdir}/* ${STAGING_LIBDIR}
30                                 break
31                         fi
32                 done
33                 oe_libinstall -so -C telepathy-glib/.libs libtelepathy-glib ${STAGING_LIBDIR}
34         fi
35         if [ -d ${STAGE_TEMP}/${datadir}/aclocal ]; then
36                 install -d ${STAGING_DATADIR}/aclocal
37                 cp -fpPR ${STAGE_TEMP}/${datadir}/aclocal/* ${STAGING_DATADIR}/aclocal
38         fi
39         rm -rf ${STAGE_TEMP}
40 }