Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / recipes / tasks / task-xfce-base.bb
1 # task-xfce-base OE build file
2 # Copyright (C) 2004, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 DESCRIPTION = "All packages required for an base XFCE installation"
6 LICENSE = "MIT"
7 PR = "r4"
8
9 inherit task
10
11 RDEPENDS_${PN} = " \
12     xfce-mcs-manager \
13     xfwm4 \
14     xfwm4-theme-default \
15     xfce-utils \
16     xfdesktop \
17     xfce4-panel \
18     xfce4-panel-plugin-actions \
19     xfce4-panel-plugin-clock \
20     xfce4-panel-plugin-iconbox \
21     xfce4-panel-plugin-launcher \
22     xfce4-panel-plugin-pager \
23     xfce4-panel-plugin-separator \
24     xfce4-panel-plugin-showdesktop \
25     xfce4-panel-plugin-systray \
26     xfce4-panel-plugin-tasklist \
27     xfce4-panel-plugin-windowlist \
28     xfce-mcs-plugins \
29     xfwm4-mcs-plugins \
30     xfce4-panel-mcs-plugins \
31     xfdesktop-mcs-plugins \
32 "
33
34 RRECOMMENDS_${PN} = "xfce-utils-mcs-plugins"