Merge branch 'opendreambox' of git://git.opendreambox.org/git/openembedded into opend...
[vuplus_openembedded] / recipes / tasks / task-slugos.bb
1 # This describes a generic SlugOS image, even though the bb file is
2 # called 'slugos-image.bb' the distro specific configuration is
3 # done in conf/distro/${DISTRO}.conf (which should always include
4 # conf/distro/slugos.conf to get the standard settings).
5 #
6 DESCRIPTION = "Task packages for the SlugOS distribution"
7 HOMEPAGE = "http://www.nslu2-linux.org"
8 LICENSE = "MIT"
9 PR = "r22"
10 PACKAGE_ARCH = "${MACHINE_ARCH}"
11 COMPATIBLE_MACHINE = "(nslu2|ixp4xx)"
12 ALLOW_EMPTY = "1"
13
14 #----------------------------------------------------------------------------------
15 # FIRMWARE CONFIGURATION
16 #----------------------------------------------------------------------------------
17 # EXTRA PACKAGES
18 # --------------
19 # The standard firmware contents and additional packages built as requirements
20 # of the firmware are defined here in SLUGOS_STANDARD_RDEPENDS.
21 SLUGOS_STANDARD_RDEPENDS = ""
22 SLUGOS_STANDARD_RRECOMMENDS = ""
23
24 # The full cpio (non-busybox) is required for turnup and sysconfig.
25 SLUGOS_STANDARD_RRECOMMENDS += "\
26 cpio \
27 "
28
29 # These lines add support for formatting ext2 and ext3 file systems
30 # on a hard disk attached to the NSLU2.  ext3 is the standard Linux
31 # file system.
32 SLUGOS_STANDARD_RRECOMMENDS += "\
33 e2fsprogs-mke2fs \
34 e2fsprogs-fsck \
35 e2fsprogs-e2fsck \
36 e2fsprogs-badblocks \
37 e2fsprogs-blkid \
38 "
39
40 # Filesystem selection.  Adding entries here adds the module to the
41 # image.  The module must be built as part of nslu2-kernel (i.e. it
42 # must be specified as a module in the defconfig file).  The NLS
43 # support charset modules must be given explicitly and must match
44 # the codepage/iocharset and NLS handling for the file systems which
45 # require them.  The installed lanugage set is minimal but sufficient
46 # for any file system (since it uses utf8).  See
47 # http://www.nslu2-linux.orgwiki/HowTo/MountFATFileSystems
48 # for more information on the language behaviour of the DOS file
49 # systems.
50 #
51 # KERNEL LEVEL FILE SYSTEM SUPPORT
52 # --------------------------------
53 # NOTE: removing kernel-module-nfs from this list will prevent NFS
54 # boot (however you can do a simple flash file system boot - no
55 # attached disk - and install the nfs modules from ssh.)
56 # The altboot mechanism requires kernel-module-loop.
57 SLUGOS_STANDARD_RRECOMMENDS += "\
58 kernel-module-ext2 \
59 kernel-module-jbd \
60 kernel-module-ext3 \
61 kernel-module-vfat \
62 kernel-module-nls-cp437 \
63 kernel-module-nls-utf8 \
64 kernel-module-nfs \
65 "
66
67 # Add daemon required for HW RNG support
68 SLUGOS_RNG_TOOLS_PACKAGE = "rng-tools"
69 SLUGOS_RNG_TOOLS_PACKAGE_linux-uclibc = ""
70 SLUGOS_STANDARD_RRECOMMENDS += "\
71 ${SLUGOS_RNG_TOOLS_PACKAGE} \
72 "
73
74 # Add modules required for usb support
75 SLUGOS_STANDARD_RRECOMMENDS += "\
76 kernel-module-ehci-hcd \
77 kernel-module-ohci-hcd \
78 kernel-module-uhci-hcd \
79 "
80
81 # Add modules required for IDE support
82 SLUGOS_STANDARD_RRECOMMENDS += "\
83 kernel-module-libata \
84 kernel-module-pata-artop \
85 "
86
87 # Add modules required for Network support
88 SLUGOS_STANDARD_RRECOMMENDS += "\
89 kernel-module-mii \
90 kernel-module-ixp4xx-mac \
91 kernel-module-ixp4xx-qmgr \
92 kernel-module-via-velocity \
93 kernel-module-netconsole \
94 "
95
96 # Add packages and modules required for RAID-1 support
97 # (temporary, intended only to facilitate testing - MJW)
98 SLUGOS_STANDARD_RRECOMMENDS += "\
99 mdadm \
100 kernel-module-md-mod \
101 kernel-module-raid1 \
102 "
103
104 # Other candidate packages that have been considered and
105 # are intentionally excluded from the base flash image.
106 #
107 # portmap \
108 # kexec-tools \
109 # kernel-module-isofs \
110 # kernel-module-udf \
111 # kernel-module-loop \
112 # wireless-tools \
113 # wpa-supplicant \
114 # zd1211-firmware kernel-module-zd1211rw \
115 # madwifi-ng-modules madwifi-ng-tools \
116
117 DISTRO_EXTRA_DEPENDS ?= ""
118 DEPENDS += "${DISTRO_EXTRA_DEPENDS}"
119
120 DISTRO_EXTRA_RDEPENDS ?= ""
121
122 ## This comment block is temporary, to be removed once SlugOS 5.0 stabilizes
123 ##RDEPENDS += "\
124 ##      kernel ixp4xx-npe \
125 ##      base-files base-passwd netbase \
126 ##        busybox initscripts-slugos slugos-init \
127 ##        update-modules sysvinit tinylogin udev \
128 ##      module-init-tools modutils-initscripts \
129 ##        ipkg-collateral ipkg ipkg-link \
130 ##      libgcc \
131 ##      beep \
132 ##      util-linux-mount \
133 ##      util-linux-umount \
134 ##      util-linux-swaponoff \
135 ##      util-linux-losetup \
136 ##      ${SLUGOS_STANDARD_RDEPENDS} \
137 ##      ${DISTRO_EXTRA_RDEPENDS}"
138 ## SlugOS 5.0 - original RDEPENDS above for reference; tinylogin and the
139 ## util-linux-* utilities are now replaced by busybox tools.  Also, ipkg
140 ## is replaced by a trimmed-down version of opkg (no package signatures,
141 ## and it uses the busybox wget command instead of libcurl - MJW
142 ## SlugOS 5.0 - module-init-tools replaced by busybox as well - MJW
143 ## SlugOS 5.2 - module-init-tools reinstated due to busybox bugs - MJW
144
145 RDEPENDS += "\
146         kernel ixp4xx-npe \
147         base-files base-passwd netbase \
148         busybox initscripts-slugos slugos-init \
149         update-modules sysvinit udev \
150         module-init-tools modutils-initscripts \
151         opkg-collateral opkg-nogpg-nocurl \
152         libgcc \
153         beep \
154         ${SLUGOS_STANDARD_RDEPENDS} \
155         ${DISTRO_EXTRA_RDEPENDS}"
156
157 DISTRO_EXTRA_RRECOMMENDS ?= ""
158 RRECOMMENDS += "\
159         openssh \
160         ${SLUGOS_STANDARD_RRECOMMENDS} \
161         ${DISTRO_EXTRA_RRECOMMENDS}"