Merge branch 'vuplus-1.6' of /var/ikseong/repo/openembedded/ into vuplus-1.6
[vuplus_openembedded] / recipes / tasks / task-opendreambox-wlan.bb
1 DESCRIPTION = "OpenDreambox: W-LAN Task for the OpenDreambox Distribution"
2 SECTION = "opendreambox/base"
3 LICENSE = "MIT"
4 PR = "r3"
5
6 inherit task
7
8 #
9 # task-opendreambox-wlan
10 #
11 DESCRIPTION_${PN} = "OpenDreambox: W-LAN Support"
12 DEPENDS_${PN} = "enigma2-plugins"
13 RDEPENDS_${PN} = "\
14   enigma2-plugin-systemplugins-wirelesslan \
15   wireless-tools \
16   wpa-supplicant \
17 "
18
19 WLAN_CRYPTO_MODULES = "\
20   kernel-module-aes-generic \
21   kernel-module-arc4 \
22   kernel-module-cryptomgr \
23   kernel-module-ecb \
24 "
25
26 WLAN_PCI_MODULES = "\
27   kernel-module-ath5k \
28 "
29
30 WLAN_USB_MODULES = "\
31   kernel-module-rt73usb \
32   kernel-module-zd1211rw \
33   rt73-firmware \
34   zd1211-firmware \
35 "
36
37 WLAN_USB_MODULES_2_6_18 = "\
38   zd1211b \
39   wlan-rt73 \
40 "
41
42 RDEPENDS_${PN}_append_dm500hd = "\
43   ${@base_contains('PREFERRED_VERSION_linux-dm500hd', '2.6.18', '${WLAN_USB_MODULES_2_6_18}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
44 "
45
46 RDEPENDS_${PN}_append_dm800 = "\
47   ${@base_contains('PREFERRED_VERSION_linux-dm800', '2.6.18', '${WLAN_USB_MODULES_2_6_18}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
48 "
49
50 RDEPENDS_${PN}_append_dm800se = "\
51   ${@base_contains('PREFERRED_VERSION_linux-dm800se', '2.6.18', '${WLAN_USB_MODULES_2_6_18}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
52 "
53
54 RDEPENDS_${PN}_append_dm8000 = "\
55   ${@base_contains('PREFERRED_VERSION_linux-dm8000', '2.6.18', 'task-opendreambox-madwifi', '${WLAN_CRYPTO_MODULES} ${WLAN_PCI_MODULES}', d)} \
56 "
57
58 PACKAGE_ARCH = "${MACHINE_ARCH}"
59