dm7025: switch back to old kernel 2.6.12.6 because of some performance issues with...
[vuplus_openembedded] / recipes / tasks / task-opendreambox-wlan.bb
1 DESCRIPTION = "OpenDreambox: W-LAN Task for the OpenDreambox Distribution"
2 SECTION = "opendreambox/base"
3 LICENSE = "MIT"
4 PR = "r3"
5
6 inherit task
7
8 #
9 # task-opendreambox-wlan
10 #
11 DESCRIPTION_${PN} = "OpenDreambox: W-LAN Support"
12 DEPENDS_${PN} = "enigma2-plugins"
13 RDEPENDS_${PN} = "\
14   enigma2-plugin-systemplugins-wirelesslan \
15   wireless-tools \
16   wpa-supplicant \
17 "
18
19 WLAN_CRYPTO_MODULES = "\
20   kernel-module-aes-generic \
21   kernel-module-arc4 \
22   kernel-module-ecb \
23   kernel-module-cryptomgr \
24   kernel-module-crypto-hash \
25   kernel-module-aead \
26   kernel-module-pcompress \
27   kernel-module-crypto-blkcipher \
28   kernel-module-crypto-algapi \
29 "
30
31 WLAN_PCI_MODULES = "\
32   kernel-module-ath5k \
33 "
34
35 WLAN_USB_MODULES = "\
36   kernel-module-rt73usb \
37   kernel-module-zd1211rw \
38   rt73-firmware \
39   zd1211-firmware \
40 "
41
42 WLAN_USB_MODULES_LEGACY = "\
43   zd1211b \
44   wlan-rt73 \
45 "
46
47 RDEPENDS_${PN}_append_dm500hd = "\
48   ${@base_contains('PREFERRED_VERSION_linux-dm500hd', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
49 "
50
51 RDEPENDS_${PN}_append_dm800 = "\
52   ${@base_contains('PREFERRED_VERSION_linux-dm800', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
53 "
54
55 RDEPENDS_${PN}_append_dm800se = "\
56   ${@base_contains('PREFERRED_VERSION_linux-dm800se', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
57 "
58
59 RDEPENDS_${PN}_append_dm8000 = "\
60   ${@base_contains('PREFERRED_VERSION_linux-dm8000', '2.6.18', 'task-opendreambox-madwifi', '${WLAN_CRYPTO_MODULES} ${WLAN_PCI_MODULES}', d)} \
61 "
62
63 RDEPENDS_${PN}_append_dm7025 = "\
64   ${@base_contains('PREFERRED_VERSION_linux-dm7025', '2.6.12.6', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
65 "
66
67 PACKAGE_ARCH = "${MACHINE_ARCH}"
68