support rt5370 AP mode.
[vuplus_openembedded] / recipes / tasks / task-opendreambox-wlan.bb
1 DESCRIPTION = "OpenDreambox: W-LAN Task for the OpenDreambox Distribution"
2 SECTION = "opendreambox/base"
3 LICENSE = "MIT"
4 PR = "r6"
5
6 inherit task
7
8 #
9 # task-opendreambox-wlan
10 #
11 DESCRIPTION_${PN} = "OpenDreambox: W-LAN Support"
12 DEPENDS = "enigma2"
13 RDEPENDS_${PN} = "\
14   enigma2-plugin-systemplugins-wirelesslan \
15   wireless-tools \
16   wpa-supplicant \
17 "
18
19 WLAN_CRYPTO_MODULES = "\
20   kernel-module-aes-generic \
21   kernel-module-arc4 \
22   kernel-module-ecb \
23   kernel-module-cryptomgr \
24   kernel-module-crypto-hash \
25   kernel-module-aead \
26   kernel-module-pcompress \
27   kernel-module-crypto-blkcipher \
28   kernel-module-crypto-algapi \
29 "
30
31 WLAN_PCI_MODULES = "\
32   kernel-module-ath5k \
33 "
34
35 WLAN_USB_MODULES = "\
36   kernel-module-rt73usb \
37   kernel-module-zd1211rw \
38   rt73-firmware \
39   zd1211-firmware \
40 "
41
42 WLAN_USB_MODULES_LEGACY = "\
43   zd1211b \
44   wlan-rt73 \
45   r8712u \
46   rt3070 \  
47 "
48
49 RDEPENDS_${PN}_append_dm500hd = "\
50   ${@base_contains('PREFERRED_VERSION_linux-dm500hd', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
51 "
52
53 RDEPENDS_${PN}_append_dm800 = "\
54   ${@base_contains('PREFERRED_VERSION_linux-dm800', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
55 "
56
57 RDEPENDS_${PN}_append_dm800se = "\
58   ${@base_contains('PREFERRED_VERSION_linux-dm800se', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
59 "
60
61 RDEPENDS_${PN}_append_dm7020hd = "\
62   ${@base_contains('PREFERRED_VERSION_linux-dm7020hd', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
63 "
64
65 RDEPENDS_${PN}_append_dm8000 = "\
66   ${@base_contains('PREFERRED_VERSION_linux-dm8000', '2.6.18', 'task-opendreambox-madwifi', '${WLAN_CRYPTO_MODULES} ${WLAN_PCI_MODULES}', d)} \
67 "
68
69 DEPENDS_append_dm8000 = "\
70   ${@base_contains('PREFERRED_VERSION_linux-dm8000', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
71 "
72
73 RSUGGESTS_${PN}_append_dm8000 = "\
74   ${@base_contains('PREFERRED_VERSION_linux-dm8000', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
75 "
76
77 RDEPENDS_${PN}_append_dm7025 = "\
78   ${@base_contains('PREFERRED_VERSION_linux-dm7025', '2.6.12.6', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
79 "
80
81 PACKAGE_ARCH = "${MACHINE_ARCH}"
82