increase dvbapp PR.
[vuplus_openembedded] / recipes / tasks / task-opendreambox-enigma.bb
1 DESCRIPTION = "OpenDreambox: Enigma Task for the OpenDreambox Distribution"
2 SECTION = "opendreambox/base"
3 LICENSE = "MIT"
4 PR = "r0"
5
6 inherit task
7
8 PROVIDES = "\
9   task-opendreambox-ui \
10   ${PACKAGES} \
11 "
12
13 PACKAGES = "\
14   task-opendreambox-enigma \
15   task-opendreambox-modem \
16 "
17
18 #
19 # task-opendreambox-enigma
20 #
21 RPROVIDES_task-opendreambox-enigma = "task-opendreambox-ui"
22 DESCRIPTION_task-opendreambox-enigma = "OpenDreambox: Enigma Dependencies"
23 DEPENDS_task-opendreambox-enigma = "\
24   tuxbox-plugins \
25   tuxbox-plugins-enigma \
26   links-dream \
27 "
28 RDEPENDS_task-opendreambox-enigma = "\
29   dreambox-keymaps \
30   enigma \
31   ipkgpl \
32   links-dream-plugin \
33   tuxbox-plugin-master \
34   tuxbox-plugin-mines  \
35   tuxbox-plugin-pacman \
36   tuxbox-plugin-snake \
37   tuxbox-plugin-soko \
38   tuxbox-plugin-sol \
39   tuxbox-plugin-solitair \
40   tuxbox-plugin-tank \
41   tuxbox-plugin-tetris \
42   tuxbox-plugin-tuxcom \
43   tuxbox-plugin-tuxmail \
44   tuxbox-plugin-tuxtxt \
45   tuxbox-plugin-vierg \
46   tuxbox-plugin-yahtzee \
47   enigma-locale-cs enigma-locale-da \
48   enigma-locale-de enigma-locale-el enigma-locale-es enigma-locale-et \
49   enigma-locale-fi enigma-locale-fr enigma-locale-hr enigma-locale-hu \
50   enigma-locale-is enigma-locale-it enigma-locale-lt enigma-locale-nl \
51   enigma-locale-no enigma-locale-pl enigma-locale-pt enigma-locale-ro \
52   enigma-locale-ru enigma-locale-sk enigma-locale-sl \
53   enigma-locale-sv enigma-locale-tr \
54   task-opendreambox-modem \
55 "
56
57 # disabled languages: enigma-locale-ar enigma-locale-sr enigma-locale-ur
58
59 RDEPENDS_task-opendreambox-enigma_append_dm7020 = "\
60   enigma-plugin-dreamdata \
61   tuxbox-plugin-lcdcirc \
62   tuxbox-plugin-satfind \
63 "
64  
65 RDEPENDS_task-opendreambox-enigma_append_dm600pvr = "\
66   enigma-blindscan \
67   dreambox-blindscan-utils \
68 "
69  
70 RDEPENDS_task-opendreambox-enigma_append_dm500plus = "\
71   enigma-blindscan \
72   dreambox-blindscan-utils \
73 "
74
75 PACKAGE_ARCH_task-opendreambox-enigma = "${MACHINE_ARCH}"
76
77 #
78 # task-opendreambox-modem
79 #
80 DESCRIPTION_task-opendreambox-modem = "OpenDreambox: Modem Support"
81 RDEPENDS_task-opendreambox-modem = "\
82   enigma-modem \
83   kernel-module-crc-ccitt \
84   kernel-module-ppp-async \
85   kernel-module-ppp-generic \
86   kernel-module-slhc \
87   update-modules \
88 "
89