[openwebif] support file transcoding.
[vuplus_openembedded] / recipes / tasks / task-mokogateway.bb
1 DESCRIPTION = "MokoGateway: Tasks for a companion server for the Openmoko Linux Distribution"
2 LICENSE = "MIT"
3 PROVIDES = "task-mokogateway-everything"
4 PR = "r6"
5
6 inherit task
7
8 PACKAGES = "\
9         task-mokogateway-everything \
10         ${MOKOGATEWAY_PACKAGES} \
11 "
12
13 MOKOGATEWAY_PACKAGES = "\
14         task-mokogateway-usbnet \
15         task-mokogateway-bluetooth \
16         task-mokogateway-wifi \
17         task-mokogateway-debug \
18 "
19
20 RDEPENDS_task-mokogateway-everything = "${MOKOGATEWAY_PACKAGES}"
21
22 DESCRIPTION_task-mokogateway-usbnet = "MokoGateway: USB Networking"
23 RDEPENDS_task-mokogateway-usbnet = "\
24         iptables \
25 "
26 RRECOMMENDS_task-mokogateway-usbnet = "\
27         kernel-module-usbnet \
28         kernel-module-cdc-acm \
29         kernel-module-cdc-ether \
30         kernel-module-iptable-nat \
31         kernel-module-ipt-masquerade \
32 "
33
34 DESCRIPTION_task-mokogateway-bluetooth = "MokoGateway: Bluetooth"
35 RDEPENDS_task-mokogateway-bluetooth = "\
36         bluez4 \
37 "
38 RRECOMMENDS_task-mokogateway-bluetooth = "\
39         kernel-module-bluetooth \
40         kernel-module-l2cap \
41         kernel-module-rfcomm \
42         kernel-module-hci-vhci \
43         kernel-module-bnep \
44         kernel-module-hidp \
45         kernel-module-hci-uart \
46         kernel-module-sco \
47         ${@base_contains("COMBINED_FEATURES", "usbhost", "kernel-module-hci-usb", "",d)} \
48         ${@base_contains("COMBINED_FEATURES", "pcmcia",  "kernel-module-bluetooth3c-cs", "",d)} \
49         ${@base_contains("COMBINED_FEATURES", "pcmcia",  "kernel-module-bluecard-cs", "",d)} \
50         ${@base_contains("COMBINED_FEATURES", "pcmcia",  "kernel-module-bluetoothuart-cs", "",d)} \
51         ${@base_contains("COMBINED_FEATURES", "pcmcia",  "kernel-module-dtl1-cs", "",d)} \
52 "
53
54 DESCRIPTION_task-mokogateway-wifi = "MokoGateway: WiFi"
55 RDEPENDS_task-mokogateway-wifi = "\
56         bridge-utils \
57         wireless-tools \
58         ${@base_contains("COMBINED_FEATURES", "madwifi", "madwifi-ng-modules", "",d)} \
59         ${@base_contains("COMBINED_FEATURES", "madwifi", "madwifi-ng-tools", "",d)} \
60         wpa-supplicant \
61 "
62 RRECOMMENDS_task-mokogateway-wifi = "\
63         kernel-module-ieee80211-crypt \
64         kernel-module-ieee80211-crypt-ccmp \
65         kernel-module-ieee80211-crypt-tkip \
66         kernel-module-ieee80211-crypt-wep \
67         kernel-module-arc4 \
68         kernel-module-michael-mic \
69         kernel-module-aes \
70         ${@base_contains("COMBINED_FEATURES", "usbhost", "kernel-module-zd1211rw", "",d)} \
71         ${@base_contains("COMBINED_FEATURES", "usbhost", "zd1211-firmware", "",d)} \
72 "
73
74 DESCRIPTION_task-mokogateway-debug = "MokoGateway: Debug"
75 RDEPENDS_task-mokogateway-debug = "\
76 "
77 # The following packages are broken -- victims of libusb confusion.
78 # These packages depend upon libusb, which provides libusb.a -- however
79 # everything else depends upon libusb-compat, which also provides libusb.a
80 # (this includes bluez-*, usbutils-*, hal-*, libhal-*, etc).  The wrong
81 # libusb.a is staged for at least somebody.  The hacky solution right now
82 # is to not build these two utils, as they are the only ones in common use
83 # that DEPEND upon libusb.  This needs to be fixed in a better way, but this
84 # will, at least, get the feeds working again.
85 #       dfu-util \
86 #       openocd \
87 #
88 # The following packages are obsolete, and have been replaced.
89 #       bluez-utils \
90
91 RRECOMMENDS_task-mokogateway-debug = "\
92 "