increase dvbapp PR.
[vuplus_openembedded] / recipes / taglib / taglib_1.5.bb
1 DESCRIPTION = "TagLib is a library for reading and editing the meta-data of several popular audio formats"
2 SECTION = "libs/multimedia"
3 HOMEPAGE = "http://developer.kde.org/~wheeler/taglib.html"
4 LICENSE = "LGPL"
5 PR = "r2"
6
7 SRC_URI = "http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz \
8            file://add_missing_exports_fix.diff;patch=1 \
9            file://gcc_visibility_feature.diff;patch=1 \
10            file://link_interface_libraries_fix.diff;patch=1 \
11           "
12
13 S = "${WORKDIR}/taglib-${PV}"
14
15 inherit cmake pkgconfig binconfig
16
17 do_stage() {
18          install -d ${STAGING_INCDIR}/${PN}
19          install -m 0644 ${D}/${includedir}/${PN}/*.h ${STAGING_INCDIR}/${PN}
20          install -m 0644 ${D}/${includedir}/${PN}/*.tcc ${STAGING_INCDIR}/${PN}
21          oe_libinstall -C ${PN} -so libtag ${STAGING_LIBDIR}
22 }
23
24 LEAD_SONAME = "libtag.so.1"
25
26 PACKAGES =+ "${PN}-c"
27
28 FILES_${PN} = "${libdir}/libtag.so.*"
29 FILES_${PN}-c = "${libdir}/libtag_c.so.*"