increase dvbapp PR.
[vuplus_openembedded] / recipes / supertux / supertux-qvga_0.1.3.bb
1 DESCRIPTION = "SuperTux is a classic 2D jump'n'run sidescroller game \
2 in a style similar to the original SuperMario games (QVGA, size-optimized version)"
3 SECTION = "games"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "libsdl-gfx imagemagick-native pngcrush-native"
7 PR = "r0.20"
8
9 APPIMAGE = "${WORKDIR}/supertux.png"
10 APPDESKTOP = "${WORKDIR}/supertux.desktop"
11
12 PACKAGES_prepend = " ${PN}-levels-bonus1 ${PN}-levels-bonus2 "
13
14 SRC_URI = "${SOURCEFORGE_MIRROR}/super-tux/supertux-${PV}.tar.bz2 \
15 #           file://supertux-qvga-gfx.tar.bz2 \
16            file://supertux-smallsize-data.tar.bz2 \
17            file://gp2x.patch;patch=1 \
18            file://img-resize.sh \
19            file://supertux.png \
20            file://supertux.desktop \
21 #          file://letters-black.png \
22 #          file://letters-blue.png \
23 #          file://letters-gold.png \
24 #          file://mousecursor.png \
25 #          file://credits.mod \
26            "
27 S = "${WORKDIR}/supertux-${PV}"
28
29 export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
30 EXTRA_OECONF = "--enable-320x240 --disable-opengl"
31
32 inherit autotools sdl
33
34 do_compile_prepend() {
35 #    for f in letters-black.png letters-blue.png letters-gold.png mousecursor.png; do
36 #       cp ${WORKDIR}/$f ${S}/data/images/status/
37 #    done
38     for d in background shared tilesets title worldmap; do
39         cd ${S}/data/images/$d
40         sh ${WORKDIR}/img-resize.sh
41     done
42 }
43
44 do_install_prepend() {
45     # *-fast.* music plays when time for a level is running out
46     # byte-wise, it's the same file with few bytes changes (for .mod's). 
47     # Well, seller feature, what to say, but we won't waste megabytes on 
48     # that. Folks should learn to control tempo in there player lib.
49     rm -f ${S}/data/music/*-fast.*
50     # ogg is too heavy for embedded systems
51     rm -f ${S}/data/music/*.ogg
52 #    cp ${WORKDIR}/*.mod ${S}/data/music/
53 }
54
55 FILES_${PN}-levels-bonus1 = "${datadir}/supertux/levels/bonus1 ${datadir}/supertux/levels/worldmaps/bonusisland1.stwm"
56 FILES_${PN}-levels-bonus2 = "${datadir}/supertux/levels/bonus2 ${datadir}/supertux/levels/worldmaps/bonusisland2.stwm"
57 FILES_${PN} += "${datadir}/supertux"