Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / subversion / subversion_1.6.5.bb
1 DESCRIPTION = "The Subversion (svn) client"
2 SECTION = "console/network"
3 DEPENDS = "apr-util neon"
4 RDEPENDS = "neon"
5 LICENSE = "Apache BSD"
6 HOMEPAGE = "http://subversion.tigris.org/"
7
8 PR = "r0"
9
10 SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
11            file://disable-revision-install.patch;patch=1"
12
13 EXTRA_OECONF = "--without-berkeley-db --without-apxs --without-apache \
14                 --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
15                 --with-apr-util=${STAGING_BINDIR_CROSS}"
16
17
18 inherit autotools
19
20 acpaths = "-I build/ac-macros"
21
22 # FIXME: Ugly hack!
23 do_configure_append() {
24         if ! test -f libtool ; then cp -a *-libtool libtool ; fi
25 }
26
27 do_stage() {
28         autotools_stage_all
29 }