increase dvbapp PR.
[vuplus_openembedded] / recipes / strace / strace_4.5.14.bb
1 DESCRIPTION = "strace is a system call tracing tool."
2 SECTION = "console/utils"
3 LICENSE = "GPL"
4 PR = "r9"
5
6 SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
7            file://glibc-2.5.patch;patch=1 \
8            file://arm-eabi.patch;patch=1 \
9            file://sh-arch-update.patch;patch=1 \
10            file://sh-syscall-update.patch;patch=1 \
11            file://strace-fix-arm-bad-syscall.patch;patch=1 \
12            file://strace-undef-syscall.patch;patch=1 \
13            file://strace-arm-no-cachectl.patch;patch=1 \
14            file://strace-dont-include-linux-dirent-h.patch;patch=1 \
15            file://mips-sigcontext.patch;patch=1 \
16           "
17
18 # The strace-4.5.14-avr32.patch conflicts with some other patches.
19 # These patches are primarly for the ARM and SuperH, so we'll just
20 # not use them when building for the AVR32.
21 # The avr32 patch also includes the drop-ctl-proc.patch
22 # The AVR32 patches are from http://avr32linux.org/twiki/bin/view/Main/STrace
23 SRC_URI_avr32 = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
24      file://strace-4.5.14-avr32.patch;patch=1 \
25      file://strace-4.5.14-avr32-add-syscalls-up-to-sysvipc.patch;patch=1 \
26     "
27
28 inherit autotools
29
30 export INCLUDES = "-I. -I./linux"